Locator Group not receiving data because other maps have unexpired Locator Groups

caver456's Avatar

caver456

14 Feb, 2021 01:00 AM

Locators (via FleetSync via radiolog / http request) haven't been reliably working for our team for quite a while. After adding a Locator Group on a newly saved map, no locator objects would show up on incoming traffic. This is still the case in 4210. For some SAR calls they work correctly. More often they don't. We couldn't figure out a pattern. I did submit a few help tickets on this topic over the past year or so.

We've been talking with at least one other team that has been having similar issues, and they seem to have found the solution. I tested out the theory and confirmed it a few times on our command trailer network running 4210:

We've been in the habit of setting 'Stop Listening' to 'Never'. So, we had many old maps with Locator Group objects that were still listening. These were apparently preventing any new locators from showing up on a newly created map.

The solution was to go to the old maps and expire all of the listeners (set the Locator Group's 'Stop Listening' field to 'Now'). This allowed the existing Locator Group on the newest map to function as expected and to create and update locators correctly on incoming traffic.

Is this a bug? Shouldn't the locator data be sent to all maps with unexpired listeners (Locator Groups)? Maybe we just had too many maps with unexpired listeners?

We do have a two-part workaround, so we're not stuck, and this is really more of a discovery that we wanted to pass along to you to see if it makes sense and if you can shed any more light on it.

Our workaround is 1) change our guidelines going forward to set 'Stop Listening' to 1 day, and 2) immediately expire listeners on many/all of our previous maps. We still have to go in and extend expiry for multi-day searches and may occasionally have to manually expire listeners on previous maps if we have multiple different back-to-back searches, but that's not so bad.

Please do let me know if you can shed any more light on this. Thanks!

  1. Support Staff 1 Posted by Julie on 16 Feb, 2021 12:21 AM

    Julie's Avatar

    Thanks for reporting this and the detailed explanation. We'll take a look at it in the next few weeks, since you have a decent work-around for now.

    Julie

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

07 Mar, 2021 05:06 PM
07 Mar, 2021 06:18 AM
07 Mar, 2021 06:05 AM
05 Mar, 2021 09:54 PM
05 Mar, 2021 07:19 PM

 

04 Mar, 2021 05:26 PM
04 Mar, 2021 05:20 PM
04 Mar, 2021 04:23 PM
04 Mar, 2021 02:53 PM
03 Mar, 2021 02:51 AM
02 Mar, 2021 07:18 PM