Unable to Calculate Profile

director's Avatar


21 Oct, 2020 04:07 PM

I am using SARTopo desktop on a Windows 10 Pro machine. I am unable to show elevation profiles of lines or do a viewshed analysis. It gets stuck on "Calculating profile - stand by".

  1. Support Staff 1 Posted by Meghan on 21 Oct, 2020 09:53 PM

    Meghan's Avatar

    Could you expand a little more on the issue you are experiencing? I can't reproduce your issue (both those features seem to be working as expected for me right now) so more information will be really helpful for us to figure out what might be going on. More specifically:

    • What browser are you using? Have you tried another browser and does it happen there as well?
    • Are both of these persistent issues or do they only seem to happen when you do certain things, such as try to do the elevation profile of a really long line?
    • Are you logged in or out? Does it happen on an unsaved or saved map? And if its saved maps, is it all saved maps or just specific ones? If its a specific one, please share the 4 digit map ID.
    • For the elevation of a line, does it happen when you checking the profile of a drawn line, using the measure tool or both?

    Sorry for all the questions but the more detail you can provide, the easier it will be for us to help you troubleshoot.

  2. 2 Posted by director on 22 Oct, 2020 01:20 PM

    director's Avatar

    All good questions:

       - I've had the same results in Chrome, Firefox, and Edge
       - They are persistent. They happen on both long and short lines
       - I am logged in. It happens on different maps, both saved and unsaved.
       It happens on all saved maps.
       - It happens when I check the profile of an existing line as well as
       when I use the measuring tool

    Let me know where to go next.

  3. Support Staff 3 Posted by Julie on 22 Oct, 2020 03:22 PM

    Julie's Avatar

    Hi Mike,

    Are you running this with the actual desktop program, as opposed to the web based? If you are running the desktop program, are you connected to the internet while doing it, and have you downloaded elevation data for the area?


  4. 4 Posted by director on 22 Oct, 2020 03:53 PM

    director's Avatar

    I disconnected from the internet to confirm I was running on the desktop
    program. I was.

    My offline coverage shows full resolution elevation data for the area I am
    mapping in.

  5. Support Staff 5 Posted by Julie on 22 Oct, 2020 04:40 PM

    Julie's Avatar

    Ok, is there any output in the stack trace? If so, please send that. Also a screenshot of the data folder with the MBTiles so we can verify they have downloaded.

  6. 6 Posted by director on 22 Oct, 2020 05:05 PM

    director's Avatar

    [image: image.png]

    The stack trace doesn't seem to be doing anything when I draw a line and
    try to profile it. Here is what was already there:
    [image: image.png]

  7. Support Staff 7 Posted by Julie on 22 Oct, 2020 07:48 PM

    Julie's Avatar

    Hey Mike,

    Sorry this is being such a pain. All I can think to try right now is to have you update (or re-update) to the latest JAR and see if that does anything. Go to https://sartopo.com/offline/app and download and install the latest JAR file (4160).


  8. 8 Posted by director on 22 Oct, 2020 07:52 PM

    director's Avatar

    I figured we were headed there. I'm not sure I'll get to it today. I'm back
    in the office on Monday and will give it a try then. Thanks for your help.

  9. Support Staff 9 Posted by Julie on 22 Oct, 2020 08:02 PM

    Julie's Avatar

    Sounds good. For what it's worth, it should be a quick and easy task.

  10. 10 Posted by director on 26 Oct, 2020 06:45 PM

    director's Avatar

    I deleted and reinstalled everything including map tiles. I'm still having
    the same problem. I tried an earlier version (4159) and still no luck. I
    then tried an even earlier version (4155) and I can now create profiles and
    viewsheds. Let me know if there is anything I can do to help you figure
    this out. You're welcome to remote into the computer if it would be

  11. Support Staff 11 Posted by Julie on 26 Oct, 2020 07:59 PM

    Julie's Avatar

    Oh, bummer. This is totally our fault, and apparently the problem has been around for a while. We've got in on the bug list now, but I am not sure how long it will take to fix.

    Sorry about that,

  12. 12 Posted by director on 26 Oct, 2020 08:03 PM

    director's Avatar

    I'm fine running the old version for a while. Let me know when it is fixed.

  13. Support Staff 13 Posted by Julie on 26 Oct, 2020 10:29 PM

    Julie's Avatar

    Will do.

  14. Julie closed this discussion on 26 Oct, 2020 10:29 PM.

  15. Julie re-opened this discussion on 11 May, 2021 09:46 PM

  16. Support Staff 14 Posted by Julie on 11 May, 2021 09:46 PM

    Julie's Avatar

    Hey Mike,

    Are you still running into this problem? I can't make it happen anymore on my end.


  17. 15 Posted by director on 12 May, 2021 05:58 PM

    director's Avatar

    It's working great. Thanks for checking in.

  18. Support Staff 16 Posted by Julie on 12 May, 2021 06:05 PM

    Julie's Avatar

    Great, thanks for the update!

  19. Julie closed this discussion on 12 May, 2021 06:05 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

13 Jun, 2021 02:37 PM
13 Jun, 2021 10:00 AM
13 Jun, 2021 08:29 AM
13 Jun, 2021 08:17 AM
12 Jun, 2021 09:23 PM


12 Jun, 2021 05:41 PM
12 Jun, 2021 01:42 AM
12 Jun, 2021 12:14 AM
11 Jun, 2021 10:25 PM
11 Jun, 2021 09:54 PM
11 Jun, 2021 09:36 PM