Creating a layer via custom source

steve.levy's Avatar

steve.levy

04 Dec, 2021 09:07 PM

I am creating a layer via custom source, type = WMS, overlay. I give it a URL template, having tried the 3 following formats: http://localhost:8088/geoserver/xlz/wms?service=WMS&version=1.1.0&request=GetMap&layers=xlz%3AnevCoRoads2_line&bbox=-121.115062703958%2C39.2014882205828%2C-120.186252530976%2C39.4294065888496&width=768&height=330&srs=EPSG%3A4326&styles=&format=application/openlayers#

http://localhost:8088/geoserver/xlz/wms?service=WMS&version=1.1.0&request=GetMap&layers=xlz:nevCoRoads2_line&bbox=-121.115062703958,39.2014882205828,-120.186252530976,39.4294065888496&width=768&height=330&srs=EPSG:4326&styles=&format= image/png&TRANSPARENT=true&FGCOLOR=0xFF0000&EXCEPTIONS=INIMAGE

http://localhost:8088/geoserver/xlz/wms?service=WMS&version=1.1.0&request=GetMap&layers=xlz:nevCoRoads2_line&bbox={left},{bottom},{right},{top}&width={tilesize}&height={tilesize}&srs=EPSG:4326&styles=&format=image/png&TRANSPARENT=true&FGCOLOR=0xFF0000&EXCEPTIONS=INIMAGE

I am running both the sartopo and geoserver servers on my pc with ports 8080 and 8088, respectively. I receive a message, Template URL is invalid.

How can I find out what is invalid about the URL? BTW, I have created layers from another WMS source with similar parameters, successfully, albeit the server was at a site on the internet.

Is there another means to add content to create an overlay?

  1. Support Staff 1 Posted by Julie on 06 Dec, 2021 11:07 PM

    Julie's Avatar

    Hi Steve,

    The first thing that is apparent to me is the EPSG projection. We can sometimes use 4326, but often not. Are you able to reproject the layer(s) into EPSG 3857? That might be the issue here.

    Thanks,
    Julie

  2. 2 Posted by steve.levy on 07 Dec, 2021 05:50 AM

    steve.levy's Avatar

    Julie,I reprojected to SRS 3857, no change, still get the same message.  BTW, I have successfully created a custom source with SRS = 4326 from a zonehaven server on the internet.
    What other possibilities could explain this error?  Any further debug that can be turned-on?
        On Monday, December 6, 2021, 03:07:39 PM PST, Julie <[email blocked]> wrote:
     
       
    |

  3. Support Staff 3 Posted by Meghan on 07 Dec, 2021 11:00 PM

    Meghan's Avatar

    Hi Steve,

    I just spoke with one of our developers and he pointed out that you are serving tiles from the same machine (http://localhost:8088). For a number of reasons, layers need to be accessible from the internet because they are loaded from the CalTopo server. You could try running an instance of Desktop on the same machine- the developer I spoke with suspected that you could get it to work.

    Hope that helps!
    Meghan

  4. 4 Posted by steve.levy on 07 Dec, 2021 11:49 PM

    steve.levy's Avatar

    Meghan, etal,I am a bit confused about what is stated below (seems to say can't serve from my pc and also that it should work in that situation?) and not sure that everyone is clear on what I have tried..1) I have an instance of geoserver running on my pc http://localhost:8088    (have run GetCapabilities on the geoserver and get results as expected)2) I have an instance of caltopo desktop running on the same pc http://localhpst:80803) In custom source in the instance of CTD I specify WMS with a URL template of:       http://localhost:8088/geoserver/NevRoads/wms?service=WMS&version=1.1.0&request=GetMap&layers=NevRoads%3AnevCoRoadsXX&bbox=-121.304688322523%2C39.0084621831266%2C-120.002447248054%2C39.5221181057284&width=768&height=330&srs=EPSG%3A3857&styles=&format=application/openlayers

    (have used SRS=EPSG:4226, also)Get the the URL is invalid                          -- See pics from prior emails --
    SO, isn't the above what the developer says should work?  What are the reasons that one can get the invalid URL message?

    When one creates a layer (that is not dynamic) how is the layer stored in sartopo (both at sartopo.com and at CTD - my local machine which may not have internet access).  I assume it is stored in some vector format, not recreated from the original source at each invocation.
    Is the syntax, version, etc shown above correct? Does caltopo have certain restrictions as to format or content?  Does one get the same error message if there is an access issue or would that generate a different message?  After I have created a layer in CTD is it stored into my account when synced to sartopo.com?  I ask cause I did not see the 'SAVE' button in CTD, but did when connected to sartopo.com.
    Is this clearer?Steve

        On Tuesday, December 7, 2021, 03:00:08 PM PST, Meghan <[email blocked]> wrote:
     
       
    |

  5. 5 Posted by steve.levy on 09 Dec, 2021 10:35 PM

    steve.levy's Avatar

    Any update per my latest inputs?

  6. Support Staff 6 Posted by Meghan on 10 Dec, 2021 12:06 AM

    Meghan's Avatar

    Hi Steve,

    We've shared your input with one of our developers and he's looking more into it. It may be a few days before we can get back to you with more information but I wanted to let you know it is still on our radar.

    Best,
    Meghan

  7. Support Staff 7 Posted by matt on 18 Dec, 2021 10:41 PM

    matt's Avatar

    Steve -

    We added a basic regex check to the entered URL, because we had people entering bad URLs and then contacting us when it didn't work. "localhost" doesn't meet the check, since we were only thinking of the web use case.

    Are you able to use 127.0.0.1 instead?

    • Matt
  8. 8 Posted by steve.levy on 19 Dec, 2021 06:41 AM

    steve.levy's Avatar

    Thank You!  That with a couple of other modifications to the entire server reference generated the expected map overlay.Sent from my Galaxy
    -------- Original message --------From: matt <[email blocked]> Date: 12/18/21 2:41 PM (GMT-08:00) To: [email blocked] Subject: Re: Creating a layer via custom source [Cal/SARTopo Desktop #1317]

  9. 9 Posted by steve.levy on 19 Dec, 2021 06:45 AM

    steve.levy's Avatar

    A question. If one selects to edit the overlay, the Overlay? entry changes from Yes - Transparent Overlay to No - Base Layer? Expected?Sent from my Galaxy
    -------- Original message --------From: matt <[email blocked]> Date: 12/18/21 2:41 PM (GMT-08:00) To: [email blocked] Subject: Re: Creating a layer via custom source [Cal/SARTopo Desktop #1317]

  10. Support Staff 10 Posted by matt on 19 Dec, 2021 06:39 PM

    matt's Avatar

    I'm not able to reproduce on the website, but that sounds like a bug I remember fixing. We just released a new desktop version yesterday, can you see if it's still an issue with that version?

  11. 11 Posted by steve.levy on 20 Dec, 2021 04:45 PM

    steve.levy's Avatar

    Matt,Getting the latest CTD did resolve the Overlay vs Base Layer issue.ThanksSent from my Galaxy
    -------- Original message --------From: matt <[email blocked]> Date: 12/19/21 10:39 AM (GMT-08:00) To: [email blocked] Subject: Re: Creating a layer via custom source [Cal/SARTopo Desktop #1317]

  12. Meghan closed this discussion on 20 Dec, 2021 07:15 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

22 Jan, 2022 02:44 PM
22 Jan, 2022 01:00 PM
22 Jan, 2022 04:23 AM
22 Jan, 2022 04:10 AM
21 Jan, 2022 11:35 PM

 

21 Jan, 2022 10:07 PM
21 Jan, 2022 10:04 PM
21 Jan, 2022 08:56 PM
20 Jan, 2022 11:46 PM
20 Jan, 2022 11:42 PM
20 Jan, 2022 04:29 PM