Lines are opaque when zooming in

christopherjenness's Avatar

christopherjenness

14 May, 2021 12:38 PM

Hi,

I made my lines set to solid but when I zoom on them they turn opaque. I have black lines that look very light grey once I zoom into them. From afar, they are solid black. Is there a way to turn this off so they stay black at all zoom levels?

  1. Support Staff 1 Posted by Meghan on 14 May, 2021 05:10 PM

    Meghan's Avatar

    I am not observing the same behavior when I zoom in on black lines with a line weight of 2, set to solid and the default style. Could you share the URL for the map where you are observing this behavior? I would like to take a look at the settings you are using for your lines. I have made this discussion private so you can share the link to your map here.

    Thank you,
    Meghan

  2. 2 Posted by christopherjenn... on 14 May, 2021 05:17 PM

    christopherjenness's Avatar

    https://caltopo.com/m/0REP

    Thanks for looking into this for me! I noticed when I grabbed the link that at the zoom level it loads at, the lines start solid and then once it fully loads they turn opaque.

    I don't care if people see the map, it's public anyways. So you can make this public if other people find it helpful too.

  3. Support Staff 3 Posted by Meghan on 14 May, 2021 07:41 PM

    Meghan's Avatar

    Thanks for sharing the map. It all looks as expected to me. Is there a particular line where you see this behavior and if so, which one? Or is it all the lines? Can you take a screenshot of the opaque line when zoomed in so I can see your view?

    Also what type and version computer OS and browser are you using? If you use a different browser, do you get the same results?

  4. 4 Posted by christopherjenn... on 14 May, 2021 08:37 PM

    christopherjenness's Avatar

    Hi,

    Thanks again for looking into this.

    I tried on two different computers and chrome, firefox, and safari (and it always looks the same). The screen shots I've attached are from Mac OS 10.14.6 on Chrome 90.0.4430.93.

    I've attached three screen shots. One where I'm zoomed out so the lines are black, and two where I've zoomed in and the lines turn grey.

  5. Support Staff 5 Posted by Ben Lantow on 14 May, 2021 08:57 PM

    Ben Lantow's Avatar

    It appears that you have the mapbuilder feature overlay on in that photo. It's not available at high zoom levels but it will become visible when zoomed in much further. It is a white overlay which is probably why you are seeing the lines become "lighter". You can turn the overlay off. Does that fix the issue you're seeing?

    Best,
    Ben

  6. 6 Posted by christopherjenn... on 14 May, 2021 09:02 PM

    christopherjenness's Avatar

    Hi Ben,

    Hmm, I thought it might be something like this, but when I was turning off layers, it wasn't fixing it. I've attached a screenshot where I turned off the mapbuilder feature overlay, and the lines are still grey.

    But what I realized is that when I turn it off and then refresh the webpage, it goes away!!! Thanks! It's a bit unfortunate I have to refresh after changing features, but I'll take it!

  7. 7 Posted by christopherjenn... on 15 May, 2021 07:20 PM

    christopherjenness's Avatar

    Sorry, I think what I said previously was not correct. Now when I try removing the feature and refreshing, the lines are still opaque.

  8. Support Staff 8 Posted by Meghan on 17 May, 2021 01:57 PM

    Meghan's Avatar

    When you refresh the page, does the MapBuilder Feature overlay become checked again? The map may be reverting to a previous state when you reload the page which would explain why the lines become opaque again. You can set certain layers/overlays to display on page load by selecting the layers/overlays you would like to display and then clicking on the information (i) icon on the left side and checking the box next to Keep These Layers.

  9. 9 Posted by christopherjenn... on 17 May, 2021 02:02 PM

    christopherjenness's Avatar

    Sorry!! This is entirely my fault. I was mixing up "MapBuilder Features" with "MapBuilder Overlap". If I turn off "MapBuilder Features", it fixes my issue, even without refreshing! Thanks so much for the patience.

  10. Support Staff 10 Posted by Meghan on 17 May, 2021 02:05 PM

    Meghan's Avatar

    No worries- I'm glad to hear you got it working for you. Thanks for using CalTopo!

    Best,
    Meghan

  11. Meghan closed this discussion on 17 May, 2021 02:05 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

 

13 Jun, 2021 08:17 AM
12 Jun, 2021 01:42 AM
12 Jun, 2021 12:14 AM
11 Jun, 2021 10:25 PM
11 Jun, 2021 09:54 PM
11 Jun, 2021 09:36 PM