Superoverlay Error in Google Earth - Error When Parsing File

Bob Miller's Avatar

Bob Miller

17 May, 2020 02:24 AM

I'd been using the superoverlay feature without incident, especially enjoying the ability to see my custom layers in GE. However, when I added a new custom layer to my account I could no longer access any of my layers in GE, even though the standard CalTopo layers continued to work fine. The resulting error message was 'Error when parsing file'. I've tried everything I can think of to resolve the issue - clearing caches, logging out, downloading a 'fresh' superoverlay file and opening it in GE but nothing has worked. Does anyone have experience with this error? Any ideas on how to resolve it?


  1. Support Staff 1 Posted by matt on 18 May, 2020 07:27 PM

    matt's Avatar

    Hi Bob -

    I'm sorry, it looks like we're not properly escaping layer names in the superoverlay XML file. The issue was your "Trails & Roads" layer; the ampersand is a reserved character in XML. I updated it to "Trails and Roads" and you should be able to use the superoverlay file again until we get the escaping issue fixed in our end.

    • Matt
  2. 2 Posted by Bob Miller on 18 May, 2020 11:52 PM

    Bob Miller's Avatar

    Thank you! That did the trick.


  3. Julie closed this discussion on 21 May, 2020 11:26 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac