simulated view: peak names not displaying, imagery not available, and a feature request

jonathanmastin's Avatar

jonathanmastin

11 Jan, 2022 11:47 PM

Hi. There are a couple issues with the Simulated View feature that I'd like some help with.

Bugs?
===========
1. peak names aren't always rendered when the view changes (because it's panned or zoomed). See attachments "no peak names", and "peak names", that I captured when viewing from location "47.4715,-121.4593"

2. imagery doesn't seem to render for Alaska. I've tried a handful of places throughout the state (Valdez, Kenai, Denali) and when I select to view Imagery, or WireImagery, i don't see any images. See attachment "no imagery in AK", that is taken when viewing from location "thompson pass"

Feature Request:
===========
3. display map objects in the simulated view. I would love to see my route, place markers, etc in the simulated view.

Thank you for this tool,
Jonathan

  1. Support Staff 1 Posted by Meghan on 13 Jan, 2022 02:14 AM

    Meghan's Avatar

    Hello Jonathan,

    Thanks for reaching out! To address the points you brought up:

    1. I notice that the peak names disappear if I pan the view past 360 degrees. If I pan less than 360 degrees, I can still pan back and forth and zoom in and out as needed. Is this what you see as well? Or are you observing something different? If you're seeing what I described, we are aware of that behavior. I can bring it up again with our development team to see if it is something they want to address but in the meantime, if you don't pan past 360 degrees, you should still see peak names.

    2. The imagery for simulated view comes from NAIP, which is only available in the continental US. We could potentially rework it to incorporate global imagery instead of NAIP at some point although this would require a good amount of development effort and we're currently in the midst of some big projects.

    3. I will submit your feature request to our development team for consideration- I agree that would be a really cool feature. However have you ever overlaid your map in Google Earth? You can export your map as a KML or KML network link and then view it in 3D in Google Earth. If you export it as a KML network link, you can even continue to make tweaks to the map in CalTopo and see those changes reflected a few seconds later in Google Earth. you can learn more about viewing CalTopo maps in Google Earth in this section of our user guide. This might even help with the second point your brought up!

    Best,
    Meghan

  2. 2 Posted by jonathanmastin on 13 Jan, 2022 06:33 PM

    jonathanmastin's Avatar

    Thanks for the speedy reply, Meghan.

    1. yes, I hadn't recognized panning past 360 as being the cause, but that does seem to be it. It's nice to know the cause even if it can't be fixed soon. Thank you.

    2. that's what I figured :(. Ok, thanks. too bad it's big lift to change out the imagery, but understand. ...and looking forward to seeing more about the big projects!

    3. thank you for submitting the request. Yes, I use the google earth integration but going back and forth between apps is just a pain that I'd like to alleviate [1]. I thought if the map objects were displayed, with imagery, in the simulated view that I could reduce the amount of time spent in GE, but...alas :). Hopefully one day Caltopo can do 3d natively.

    I appreciate you all and all the work you do to help us travel in the outdoors,
    Jonathan

    [1]. https://help.caltopo.com/discussions/features/6769-request-for-3d-viewing-like-google-earth-fatmap

  3. Julie closed this discussion on 13 Jan, 2022 08:25 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

22 Jan, 2022 02:44 PM
22 Jan, 2022 01:00 PM
22 Jan, 2022 04:23 AM
22 Jan, 2022 04:10 AM
21 Jan, 2022 11:35 PM

 

21 Jan, 2022 10:07 PM
21 Jan, 2022 10:04 PM
21 Jan, 2022 08:56 PM
20 Jan, 2022 11:46 PM
20 Jan, 2022 11:42 PM
20 Jan, 2022 04:29 PM