Performance Issues

tv98199's Avatar

tv98199

16 Sep, 2021 06:13 PM

First, here is my map: https://caltopo.com/m/1GV94

When I load this map it takes about 10 seconds to load, and more delay to start using the map. I have exported this to KML and imported it with Google My Maps: https://www.google.com/maps/d/viewer?mid=1SxhnInIPyVI0QDeJ7R5ElRtw1v6AIebV&ll=43.038954522564865%2C-119.10305896688499&z=9

With Google My Maps it loads and is usable INSTANTLY. It is a direct export and contains the same number of objects. So, it appears to me that some performance enhancements are needed. I have another Caltopo map that takes far too long to load: https://caltopo.com/m/QN21S (don't click on this unless you plan to go to lunch :)

Also one other issue: I have defined a line on that map that is a dotted black line. It appears nicely on Firefox, but on Chrome it is a series of black blocks (line is located bottom-center-left).

  1. Support Staff 1 Posted by Meghan on 17 Sep, 2021 12:12 AM

    Meghan's Avatar

    Both of those maps loaded pretty quickly for me when I clicked them although I will agree that they were a bit slow to work with. Large maps with lots of data on them (like yours) can really slow down the performance of the program. We are looking into making some improvements of the performance of large maps but in the meantime, I would suggest doing the following:

    • Break the large map up into numerous smaller maps
    • Organize map objects that you don't need to immediately reference into folders and set those folders to not be visible on page load. More information on changing folder visibility can be found in this section of our user guide
    • Turn off labels or set labels to be visible by folder. More information on changing label settings can be found in this section

    And I'm not sure what line you were talking about that appears differently in different browsers- which map was it on and what is the name of the line?

    Thank you,
    Meghan

  2. 2 Posted by tv98199 on 17 Sep, 2021 03:07 AM

    tv98199's Avatar

    Thank you for the info on labels by the way. I enabled it by folder. I
    made most folders 'hidden', then, upon reloading the page, all labels
    returned. They did not stay saved. All folders returned to all labels
    visible.

    Two screenshots. The correct one on Firefox is a black line made of
    circles. The incorrect one on Chrome has black blocks.
    [image: Screenshot from 2021-09-16 20-03-37.png]
    [image: Screenshot from 2021-09-16 20-04-22.png]

  3. Support Staff 3 Posted by Julie on 17 Sep, 2021 04:38 PM

    Julie's Avatar

    Looks like the labels not staying off is a bug. We'll have to fix that.

    The line appearing different between the browsers is actually because you are not logged in to the program on Chrome. The program actually has different map engines for whether a user is logged in or not, and sometimes it renders custom things like this line type differently.

    Thanks,
    Julie

  4. Julie closed this discussion on 17 Sep, 2021 04:38 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac