After Android factory reset can't synch maps

john's Avatar

john

07 Sep, 2021 04:04 AM

I had to do a factory reset on my Pixel 4 XL. After getting the phone running again, downloading CalTopo and opening it with my account, it would not synch my maps. It is connected via WiFi. I did see a note this can take a while (and I do have a number of maps, some big) However there is no indication of anything happening when I am on the App Maps page. (Refresh circles for a minute or so, then stops with no maps being listed.)

  1. 1 Posted by john on 07 Sep, 2021 04:26 PM

    john's Avatar

    More info this AM:
    Last night I deleted old unused Credentials. Did not help
    This AM I tried accessing my maps on my factory reset Pixel 4XL, but the app did not respond (I can see various map layers and my location)
    I also tried synching my account (in Account) and got "Error syncing account!" message.
    I just recorded a simple track around the house and saved it: It immediately disappeared from the phone, but I found it under tracks on my browser and was also able to turn it on on my phone from the tracks list.

  2. Support Staff 2 Posted by Julie on 07 Sep, 2021 04:55 PM

    Julie's Avatar

    HI John,

    What app version are you using and what version of Android? Did you complete all the Android updates after the factory reset? Have you tried logging out of the app and logging in again? How about restarting the phone? Reinstalling the app?

    If none of those things work, could you send us some screen shots of the error pages and describe in as much detail as possible the steps taken to get there?

    Thanks,
    Julie

  3. 3 Posted by john on 07 Sep, 2021 07:38 PM

    john's Avatar

    Thanks for getting back to me Julie.
    I now realize that the phone is still having battery issues, keeping it
    from fully updating.
    I plan to get the battery fixed tomorrow, then hopefully I'll be able to
    get everything made current.

    I'll let you know.

    -John Thomson

  4. 4 Posted by john on 08 Sep, 2021 03:45 PM

    john's Avatar

    Julie;
    My phone (re battery & resets) seems totally ok this AM, but still can't
    load my stuff onto it.
    I can record tracks and they get saved to my account, but can't load "My
    Data" into the phone (it is there when accesse via browser)
    I uninstalled the app a couple of times and reinstalled it (note the
    mulitple credentials, the last I dated so I could see it)
    As far as I can tell Android is up to date. (See screen captures)
    From my browser:

    From my phone:

    -John Thomson

  5. Support Staff 5 Posted by Meghan on 08 Sep, 2021 06:40 PM

    Meghan's Avatar

    Hi John,

    Sorry to hear you are still having trouble. Simply uninstalling/reinstalling the app doesn't dump the local app data on Androids so if there was a bad database sync (such as it looks like you had) then the issue would still persist.

    Try clearing uninstalling the app and then clearing all local CalTopo app data from your phone. How to do this will be dependent on your phone and version of Android, but typically its under Apps - CalTopo - Data or something along those lines- a quick Google search should give you the exact steps. Once you've done that, try reinstalling and let us know if your issue resolves.

    Best,
    Meghan

  6. 6 Posted by john on 09 Sep, 2021 03:07 AM

    john's Avatar

    I tried that:
    -Settings
    -Apps & Notifications
    -All 222 apps
    -CalTopo
    -Storage & Cache
    -Clear Storage
    -Confirmed deletion of all files, accounts, databases, settings...

    No improvement: still can't synch maps and tracks visible in browser

    BTW a new battery was put in the phone this am per Googles extended
    warranty

    Issue appears to be at your end. Do I have too much in my map and tracks
    database?

    -John

  7. Support Staff 7 Posted by matt on 09 Sep, 2021 07:25 PM

    matt's Avatar

    John -

    I'm sorry, this was a bug on our end, but related to your account. We released a change a few days ago that accidentally began sending non-minimized versions of all your track and PDFs when the app initially syncs. This was 100+ megabytes of data and the app couldn't cope. I'm surprised that we didn't have more complaints; for an issue affecting any user with lots of account data, I would have expected that.

    I've fixed the bug. Not sure if the app will automatically fix itself or if you'll need to logout / login, or possibly even clear storage again - it depends on how successful the app was in syncing the large amount of data the server was sending it.

    Thanks for working with us to debug the issue.

    • Matt
  8. 8 Posted by john on 10 Sep, 2021 02:56 PM

    john's Avatar

    I noticed the full list of my maps on the phone last night. As i only have
    minimal 3g in Great Basin NP i havent tried much more. Will let you know if
    any orobs

    -John

  9. Support Staff 9 Posted by Meghan on 10 Sep, 2021 03:25 PM

    Meghan's Avatar

    Thanks for the update John! Please let us know if you have any further problems. Thanks for using CalTopo!

    Best,
    Meghan

  10. Meghan closed this discussion on 10 Sep, 2021 03:25 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

22 Oct, 2021 01:31 AM
21 Oct, 2021 06:25 PM
21 Oct, 2021 05:04 PM
21 Oct, 2021 04:39 PM
19 Oct, 2021 09:25 PM

 

19 Oct, 2021 07:54 PM
19 Oct, 2021 07:38 PM
19 Oct, 2021 04:33 PM
19 Oct, 2021 04:01 PM
19 Oct, 2021 03:51 PM
19 Oct, 2021 12:08 AM