Measure Terrain Statistics is Broken

Chris's Avatar

Chris

27 Jul, 2021 05:28 PM

I can't seem to get the measure terrain stats feature to work anymore. I can draw a line and click the terrain status but if I try to use the measure tool the whole page goes unresponsive.

Nothing prints in the console log. All buttons stop working. I cannot scroll. Resizing the page fails to redraw anything.

I'm using Chrome Version 91.0.4472.164 on a Macbook Pro. With teh forest service map, normal gradient shading at 20% and gradient slope shading turned on.

  1. Support Staff 1 Posted by Meghan on 27 Jul, 2021 05:41 PM

    Meghan's Avatar

    Hi Chris,

    Sorry to hear you are running into issues but thank you for the detailed reproduction steps. So far I've been unable to reproduce your issue- I'm on a Macbook pro as well Chrome version 92.0.4515.107. Same base layers and overlays and using the Measure tool to access Terrain Stats works as expected for me. If you try it in a different browser (such as Safari or Firefox), do you get the same result? Does upgrading Chrome resolve the issue?

    Thank you,
    Meghan

  2. 2 Posted by Chris Hluchan on 27 Jul, 2021 06:22 PM

    Chris Hluchan's Avatar

    Meghan,

    I just tried on Safari and I got the same result. I also tried this on a
    Chromebook and got the same result. The page goes unresponsive.

    Here is a screencast if it helps:
    https://drive.google.com/file/d/1fb_DAWPFmLfqFRllU_w9KxylOpqK7Wuu/view?usp=sharing

    I notice on my mac that if I try it over and over again, occasionally it
    works. Most of the time it doesn't. When it works, it loads the stats
    pretty much instantly.

    - Chris

  3. Support Staff 3 Posted by Meghan on 28 Jul, 2021 12:32 AM

    Meghan's Avatar

    Thanks for the screencast- that's really helpful. And just to confirm, you don't get any errors in the Chrome dev console (vertical 3 bar menu> More Tools> Developer Tools> Console) when the page becomes unresponsive?

  4. 4 Posted by Chris Hluchan on 28 Jul, 2021 12:48 AM

    Chris Hluchan's Avatar

    Right. I was never able to get anything on the console when the error
    happens. There are two warnings in the console when the page starts up.

    Both are identical:
    DevTools failed to load source map: Could not load content for
    https://caltopo.com/static/css/main.css.map: HTTP error: status code 404,
    net::ERR_HTTP_RESPONSE_CODE_FAILURE

    No further console logs or errors that I can detect show when I try to get
    the terrain statistics.

    Your code is minimized so it's hard to really tell, but I think maybe
    there's an endless loop in GraphUtils.getInteriorPoints
    Take that with a huge grain of salt because I don't actually have access to
    your code. If I pause execution while the screen is frozen, it's always in
    the same place and I think it's this function.

  5. Support Staff 5 Posted by Meghan on 28 Jul, 2021 05:56 PM

    Meghan's Avatar

    Chris,

    I was actually able to reproduce your issue when I draw a line to measure the terrain stats. However if I draw a polygon, terrain stats for the measured area display as expected and the page remains responsive.

    I will pass this along to our development team to address since I don't think the page going unresponsive when you measure a line is the expected behavior. In the meantime, if you draw a polygon instead of a line using the Measure> Terrain Stats tool, does it work as expected for you?

  6. 6 Posted by Chris Hluchan on 28 Jul, 2021 06:04 PM

    Chris Hluchan's Avatar

    Thanks! A polygon seems to work.

  7. Support Staff 7 Posted by Meghan on 28 Jul, 2021 06:14 PM

    Meghan's Avatar

    Thanks for the update, Chris! And thanks for takin the time to report the issue- I've passed it along to the team to address.

    Best,
    Meghan

  8. Meghan closed this discussion on 28 Jul, 2021 06:14 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

24 Sep, 2021 01:18 AM
23 Sep, 2021 11:43 PM
23 Sep, 2021 02:31 PM
22 Sep, 2021 05:02 PM
22 Sep, 2021 02:21 PM

 

22 Sep, 2021 02:17 PM
21 Sep, 2021 09:10 PM
21 Sep, 2021 09:01 PM
21 Sep, 2021 07:41 PM
21 Sep, 2021 06:38 PM
21 Sep, 2021 04:33 PM