App Issue - offline maps partially not displaying

Sean Buckley's Avatar

Sean Buckley

05 Jul, 2021 11:08 AM

Hi,

When using the app, a portion of my downloaded offline maps disappear when I zoom in and out from my current location. Only when I zoom out extensively does the area of the map around my current position become visible. Please note, my current position on the screen, as shown by the blue dot, ALWAYS remains visible - it's the map that disappears. When this occurs, I'm in airplane mode, my cache is clear, and I'm utilizing offline maps that I've used previously. Attached are 2 screen shots showing this issue occurring, as well as a 3rd screen shot confirming that my cache was clear.

This is the 2nd time I've reported this issue. The issue is repeatable. I'm a longtime subscription user of your desktop software, however I'm getting concerned about the reliability of the app.

Thanks,
Sean

  1. 1 Posted by Sean Buckley on 05 Jul, 2021 11:23 AM

    Sean Buckley's Avatar

    If it's helpful, I'm using an iPhone 12 Pro Max, iOS14.6, CalTopo App 0.7.10

    Also, attached are 3 more screenshots showing this problem occurring as I zoom in on a random area of the map that is distant from where I'm located. You'll notice Silver Lake Peak appears in the 1st screen shot, and then larger and larger portions of the the map around the peak disappear in the subsequent zoom screen shots.

  2. Support Staff 2 Posted by Julie on 05 Jul, 2021 02:45 PM

    Julie's Avatar

    HI Sean,

    This is what happens when you have layers cached, but not downloaded. Cached tiles do not work offline.

    I can't find an account with this email address, so I am unable to confirm what is going on. What email address and provider do you use to login?

    Best,
    Julie

  3. 3 Posted by Sean Buckley on 07 Jul, 2021 04:17 PM

    Sean Buckley's Avatar

    Julie,

    My typical workflow when preparing the app for a dayhike is I download the base map (usually Caltopo map builder) plus any relevant layers, then I put my phone into airplane mode, and finally I clear my cache. Additionally, when this problem has occurred, which is multiple times over the past month, I've checked my cache to make sure it's cleared. Am I missing a step to ensure any cached tiles have been cleared?

    Also, if it's helpful, my problem seems very similar to what user "ambrehm" is experiencing.

    My account is under e-mail: [email blocked]

    Thanks,
    Sean

  4. 4 Posted by Sean Buckley on 07 Jul, 2021 04:30 PM

    Sean Buckley's Avatar

    My account is under: sean dot flesher dot buckley at gmail dot com

  5. Support Staff 5 Posted by Julie on 07 Jul, 2021 05:33 PM

    Julie's Avatar

    Thanks Sean,

    We're going to look into this some more. It seems like it may be specific to that phone model. Might need to ask you some more questions soon.

    Thanks,
    Julie

  6. Support Staff 6 Posted by matt on 08 Jul, 2021 04:50 AM

    matt's Avatar

    Hi Sean -

    I can't find a previous message in our help system tied to your name. Can you provide a link, or do you know the date of your original request? Having a previous known-bad time would help with debugging.

    There's no need to clear the cache - can I ask why you're doing that?

    It looks like you're using iOS - can you send me a directory listing of the app's "Tiles" folder? You can do this with the Files app; please click on the 3-dot-circle icon at the top right and choose "list" so that I can see file sizes in addition to the full name.

    All of your screenshots appear to cut off at a 15x15 minute boundary, which y single zoomed-out tile straddles the boundary of our 15x15 minute download blocks. So when zoomed out, you'll appear to have some coverage for a given area since you're seeing a single tile, and then when you zoom in you'll no longer see map data, since you haven't actually downloaded high-zoom tiles for that area.

    • Matt
  7. 7 Posted by sean.buckley1 on 10 Jul, 2021 03:13 AM

    sean.buckley1's Avatar

    No content.

  8. 8 Posted by sean.buckley1 on 10 Jul, 2021 12:41 PM

    sean.buckley1's Avatar

    Matt,

    Attached are the first 7 screens of my CalTopo app tiles folder. Is this what you’re looking for?

    I first experienced this issue on 4/24/21, which was the first time I used the app in offline/airport mode; link to original request: https://help.caltopo.com/discussions/bugs/5566-offline-base-layer-issue-wapp

    I’ve been clearing my cache prior to going into the backcountry because of the feedback I received based from my original request, which suggested clearing my cache.

    Yes, it appears in my second example that Silver Lake Peak is on the boundary of the 15 x 15 minute quad, and indeed I did not have the quad to the north of the peak downloaded. However, in my first example, although Ampersand Mt. and the trail shown in my screen shots is close to the quad’s boundary, I had all of the adjacent quads downloaded.

    Occasionally, when this issue occurs, rotating my phone from portrait to landscape and zooming in and out a few times temporarily allows the surrounding map to appear. Also, occasionally, if I close the app (not just send it to the background), upon re-opening the app, the problem resolves itself for a few minutes. These two methods have temporarily resolved the issue perhaps 20% of the times it's occurred.

    Thanks for your help in resolving this.

    Sean

  9. Support Staff 9 Posted by matt on 13 Jul, 2021 12:11 AM

    matt's Avatar

    Thanks.

    Sorry for the confusion, but the reason Meghan asked you to clear your cache on the previous thread was so that you could verify that map tiles were downloaded and properly working offline, instead of unknowingly getting a result from the cache for the specific area you were looking at, but not having coverage for other parts of the download area. It's not something that helps with performance or something you need to do for each download.

    It looks like you have too many files downloaded for screenshots to work well - instead, can you confirm the file names (and ideally sizes, but lets skip that for now if it's tricky) of all files ending with 44-74-00.mbtiles (which is Ampersand Mountain)? Also the names of any .sqlite files in the tiles folder?

  10. 10 Posted by Peter Daniels on 25 Jul, 2021 04:29 PM

    Peter Daniels's Avatar

    I am experiencing this issue, too. Android OS. Should I start a new thread/bug or work within this one?

  11. Support Staff 11 Posted by Julie on 26 Jul, 2021 03:47 PM

    Julie's Avatar

    Hi Peter,

    Here on this thread is fine. We're still working on diagnosing this issue. We might have some questions for you as we work on it.

    Thanks,
    Julie

  12. 12 Posted by Noah on 04 Aug, 2021 05:44 AM

    Noah's Avatar

    Hi Julie,

    Same issue here on both an iPhone 6 and 8. My friend also has the same issue on Android. We are currently putting our Caltopo maps into the Avenza app until this bug is resolved.

  13. Support Staff 13 Posted by Meghan on 05 Aug, 2021 04:31 PM

    Meghan's Avatar

    As Julie said, we are actively investigating this issue. Peter and Noah, could you please provide the following information about your particular experience:

    • Type of mobile device, OS type and version and version of the CalTopo mobile app that you are currently using
    • Coordinates for where the problem(s) occurred and which base layer(s) you had downloaded for that area
    • A screenshot of the map viewer showing the problem area(s) and the download base layers page
    • Screenshots or a listing of the mbtiles files. If you need help finding this, please let us know and we can give you instructions based on your OS.
    • Any error messages you received (if any)

    Thank you for providing the above information and thank you for your patience as we dig into this issue!
    Best,
    Meghan

  14. 14 Posted by Sean Buckley on 05 Aug, 2021 04:41 PM

    Sean Buckley's Avatar

    I will be out of the office and away from e-mail through Sunday 8/22 ,
    returning to the office on Monday 8/23.
    If you need an immediate response, please contact Denise Houle at
    [email blocked] <mailto:[email blocked]> or at (860) 230-0859 Ext.
    223

    Sean Buckley
    Project Manager
    Engineered Construction International, Inc.
    PO Box 191 / 57 East Main Street
    Plainfield, CT 06374
    Ph: (860) 230-0859 Ext. 224
    Cell: (860) 942-0334

  15. 15 Posted by lgordon on 06 Aug, 2021 09:33 PM

    lgordon's Avatar

    I'm also experiencing this issue with an iPhone 12 mini w/ Caltopo 0.8.8 with the Mapbuilder topo and USFS maps.

    Can't seem to replicate it now that I'm back home.

  16. 16 Posted by Sean Buckley on 09 Aug, 2021 11:41 AM

    Sean Buckley's Avatar

    I will be out of the office and away from e-mail through Sunday 8/22 ,
    returning to the office on Monday 8/23.
    If you need an immediate response, please contact Denise Houle at
    [email blocked] <mailto:[email blocked]> or at (860) 230-0859 Ext.
    223

    Sean Buckley
    Project Manager
    Engineered Construction International, Inc.
    PO Box 191 / 57 East Main Street
    Plainfield, CT 06374
    Ph: (860) 230-0859 Ext. 224
    Cell: (860) 942-0334

  17. Support Staff 17 Posted by matt on 09 Aug, 2021 08:24 PM

    matt's Avatar

    We've identified two issues here:

    1) if a supporting file fails to download (e.g. elevation data when downloading MapBuilder Topo), the square will still show as light blue, ie partial coverage.

    2) Due a semi-recent change, if elevation or canopy data are missing, MapBuilder Topo will generate a blank tile rather than that's missing hill/vegetation shading.

    #1 is going to wait on a revised downloader we're working on, which will likely be ready in the 3-4 week timeframe. We have a fix for #2 in beta testing; you can join the beta test group via the following links:

    Android: https://play.google.com/apps/testing/com.caltopo.android
    iOS: https://testflight.apple.com/join/PP11ijJW

    I'm not quite ready to declare victory yet, since at least one of the reports in this thread appeared to have all the required files included in the directory listing - but if the issue is still reproducible for you in a given location with airplane mode on, we'd appreciate feedback on whether the beta release fixes the issue.

  18. 18 Posted by Sean Buckley on 10 Aug, 2021 12:29 PM

    Sean Buckley's Avatar

    I will be out of the office and away from e-mail through Sunday 8/22 ,
    returning to the office on Monday 8/23.
    If you need an immediate response, please contact Denise Houle at
    [email blocked] <mailto:[email blocked]> or at (860) 230-0859 Ext.
    223

    Sean Buckley
    Project Manager
    Engineered Construction International, Inc.
    PO Box 191 / 57 East Main Street
    Plainfield, CT 06374
    Ph: (860) 230-0859 Ext. 224
    Cell: (860) 942-0334

  19. Ben Lantow closed this discussion on 10 Aug, 2021 02:46 PM.

  20. Peter Daniels re-opened this discussion on 11 Aug, 2021 08:21 PM

  21. 19 Posted by Peter Daniels on 11 Aug, 2021 08:21 PM

    Peter Daniels's Avatar

    Here are some screen shots. I'm on a Samsung galaxy s10+, latest Android. The top image is after downloading. The bottom one is with downloads deleted. You can see the sections of trail that are missing and then return.

    [Image]

    [Image]

    Sent from my Verizon, Samsung Galaxy smartphone
    Get Outlook for Android<https://aka.ms/AAb9ysg>

    ________________________________

  22. 20 Posted by Sean Buckley on 11 Aug, 2021 08:47 PM

    Sean Buckley's Avatar

    I will be out of the office and away from e-mail through Sunday 8/22 ,
    returning to the office on Monday 8/23.
    If you need an immediate response, please contact Denise Houle at
    [email blocked] <mailto:[email blocked]> or at (860) 230-0859 Ext.
    223

    Sean Buckley
    Project Manager
    Engineered Construction International, Inc.
    PO Box 191 / 57 East Main Street
    Plainfield, CT 06374
    Ph: (860) 230-0859 Ext. 224
    Cell: (860) 942-0334

  23. Support Staff 21 Posted by Ben Lantow on 11 Aug, 2021 09:30 PM

    Ben Lantow's Avatar

    Hi Peter,
    This is a totally different thing happening, though I understand why it looks like an issue. A lot of the data for trails is sourced from open street map. The downloaded tiles in that area haven't been updated in a long while, and this changeset (https://www.openstreetmap.org/changeset/72115242#map=15/37.7809/-10...) includes changes to those trails, that you are seeing reflected in the online tiles, but not in the downloaded tiles. We're going to be rolling some changes to tile generation that will result in downloaded tiles being updated more frequently but that is the reason for the discrepency.

    Best,
    Ben

  24. Ben Lantow closed this discussion on 11 Aug, 2021 09:30 PM.

  25. lgordon re-opened this discussion on 15 Aug, 2021 05:32 PM

  26. 22 Posted by lgordon on 15 Aug, 2021 05:32 PM

    lgordon's Avatar

    I experienced this issue again (or at least it appears similiar) so I'll post it here. I was using MapBuilderTopo with the areas downloaded. I had poor/intermittent cell reception and was in power saving mode on my iPhone 12 mini. Using the latest testflight beta of Caltopo 0.8.11. I would occasional experience blank areas. I tried to put it into airplane mode and maybe that helped. Resetting the app also seemed to fix it sometimes. I've attached a representative screen shot. I'm not sure if this could be related to the zoom-level of the downloaded map? If so, it would be great to see a blurry version instead of blank nothingness. Please let me know if I can provide any more info.

  27. Support Staff 23 Posted by matt on 16 Aug, 2021 02:30 PM

    matt's Avatar

    Are you able to send me a listing of all 37-122-32 files in the app's "tiles" folder? Also, it may be too late, but if not, what layers did you have turned on? Looks like MapBuilder Topo + MapBuilder Overlay, but not sure if there are others I'm not seeing.

    That screenshot appears to be at zoom 15, which is the "standard" resolution download for both of those layers. When going to zooms 16 or above, if we don't have a tile, we do blow up one of the z15 tiles - if you've downloaded a standard resolution copy of a map layer, then (barring bugs in the app) you should see the map at all zoom levels.

  28. 24 Posted by Peter Daniels on 16 Aug, 2021 08:50 PM

    Peter Daniels's Avatar

    This comment was split into a new private discussion: App Issue - offline maps partially not displaying

    I'd like to suggest that we consider scheduling a teams /zoom meeting where we can go over some of these together rather than continuing a slow back-and-forth via this issue's message thread.

    Sent from my Verizon, Samsung Galaxy smartphone
    Get Outlook for Android<https://aka.ms/AAb9ysg>

    ________________________________

  29. 25 Posted by lgordon on 16 Aug, 2021 11:35 PM

    lgordon's Avatar

    Hi Matt,

    I went into the folder via Storage in the iPhone settings and the list is pretty long (would take like 10 screenshots to grab this, not sure if there is an easier way to send you the list? There seem to be a few 37-122-32 (canopy, udem). Not sure if the list is searchable so I might have missed one.

    I believe I just had Mapbuildertopo without any overlays. I might have still had the "Fire Activity" on but I don't think so.

  30. Support Staff 26 Posted by matt on 17 Aug, 2021 04:08 AM

    matt's Avatar

    lgordon - can you confirm if you have mapbuilder_topo-37-122-32 and nlcd-37-122-32 files? Sorry, I probably should have led with the prefixes to check for.

    Also if you have the mapbuidler_overlay-37-122-32 file? That screenshot definitely has MapBuilder Overlay turned on. I think it's unlikely that the MapBuilder Topo tiles would have been backed up behind failed Overlay requests, but it would be nice to check that box as well.

  31. 27 Posted by Sean Buckley on 17 Aug, 2021 01:35 PM

    Sean Buckley's Avatar

    I will be out of the office and away from e-mail through Sunday 8/22 ,
    returning to the office on Monday 8/23.
    If you need an immediate response, please contact Denise Houle at
    [email blocked] <mailto:[email blocked]> or at (860) 230-0859 Ext.
    223

    Sean Buckley
    Project Manager
    Engineered Construction International, Inc.
    PO Box 191 / 57 East Main Street
    Plainfield, CT 06374
    Ph: (860) 230-0859 Ext. 224
    Cell: (860) 942-0334

  32. 28 Posted by curt.palm on 18 Aug, 2021 05:35 PM

    curt.palm's Avatar

    I've had the same issue when hiking the HST. attached are screenshots, of the blank areas and of the download screen indicating all the map tiles have been downloaded. i have an iPhone 12 iOS 14.6 I'm not sure which version of the sartopo app i was using, it got upgraded when I got home.

  33. Support Staff 29 Posted by matt on 18 Aug, 2021 06:00 PM

    matt's Avatar

    Curt -

    Your screenshots with the missing tiles have MapBuilder Hybrid as the base layer. Do you know if you downloaded aerial imagery for that location? The downloader screen may not give an accurate picture as we recently switched from NAIP to a "global imagery" layer as our source - previously downloaded NAIP data will be used for MapBuilder Hybrid, but won't show as a highlighted box on the download screen.

    If you look in the tiles folder, these will be either naip- or imagery- files with 36-118-33 in the name.

    • Matt
  34. 30 Posted by lgordon on 18 Aug, 2021 06:44 PM

    lgordon's Avatar

    I have mapbuilder_topo-37-122-32 and nlcd-37-122-32. I don't think I have the overlay, I may have inadvertently left it on as I was previously using it over the USFS map in another area but it wasn't really doing anything on the MapbuilderTopo and I don't think I would have downloaded for offline use in Marin.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • IMG_3513.PNG 2.53 MB
  • IMG_3514.PNG 2.19 MB
  • IMG_3515.PNG 862 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

26 Oct, 2021 06:15 PM
26 Oct, 2021 05:52 PM
26 Oct, 2021 05:31 PM
26 Oct, 2021 05:28 PM
26 Oct, 2021 05:19 PM