Chrome?Firefox Fails

dydxdx's Avatar

dydxdx

21 Apr, 2021 10:56 PM

Not too big of a deal, but I can't pull up Caltopo on subject browsers. I can pull up Caltopo OK on Brave & Edge. Win10 system. This is evident on both my desktop, and Surface Pro. First noticed with the rollout of the new GUI...any thoughts?

Thanks in advance.

  1. Support Staff 1 Posted by Julie on 22 Apr, 2021 03:05 PM

    Julie's Avatar

    Hey,

    Lots of questions here -
    - I assume you refreshed a few times on each of these? IE does it continue to happen? - If you go to an incognito window, does it work properly? Sometimes plugins will interfere. - If it continues to happen, we'd love to have a copy of the JavaScript output from the console if you wouldn't mind grabbing that for us.

    Thanks
    Julie

  2. 2 Posted by jimlarkey on 22 Apr, 2021 04:32 PM

    jimlarkey's Avatar

    Refresh, yes. Occurred over several days with complete reboot on 2 machines...desktop, and Surface Pro. 1st happened with new UI.

    Cleared cache on desktop, disabled plugins, and note difference window display on 2 different browsers. Edge & Brave browsers work fine.

    The Surface Pro never in it’s history had tried to access Caltopo, since I use desktop only for backup of financial proggies. So that was a virgin login attempt for the Surface Pro. Surface Pro Chrome/Firefox displays the same image as the desktop Chrome/Firefox.

    JavaScript attached.

    Thanks for being there.
    Jim

  3. Support Staff 3 Posted by Ben Lantow on 23 Apr, 2021 03:47 AM

    Ben Lantow's Avatar

    Hi Jim,
    Took a look at these logs with one of our engineers, the security settings you have set on those browsers is such that its not allowing the Caltopo application to run. Compared to the "typical" browser settings, these security settings are much more locked down. We will look into the issues they are flagging based on those logs but cannot promise a quick fix. I'm glad for the moment being you have a functional work around, but we'll work on figuring out what we can do to get this working in your specific use case.

    Best,
    Ben

  4. Ben Lantow closed this discussion on 23 Apr, 2021 03:47 AM.

  5. jimlarkey re-opened this discussion on 23 Apr, 2021 06:30 PM

  6. 4 Posted by jimlarkey on 23 Apr, 2021 06:30 PM

    jimlarkey's Avatar

    S O L V E D....

    Hi Ben,

    Thread is locked, but thought I’d get back to you on what I discovered, which may impact others.

    CHROME:
    I am running the latest version, 90.0.4430.85, and defaults to HTTPS (not HTTP), resulting in my in ability to get to the login page on Caltopo. This is a new change for Chrome, and more here: https://www.techradar.com/nz/news/google-chrome-90-with-default-https-rolls-out

    FIREFOX:
    I am running latest version, 88.0. What I found was that the security mode was set to “Enable HTTPS-Only, in all windows”. I don’t recall overtly setting this level. What I am suggesting is that like Chrome, the rollout of v88.0 defaulted to HTTPS-Only.

    So Firefox works now, and Chrome I still need to find the setting.

    Perhaps Caltopo can use HTTPS for their opening page, before login, to preclude these issues in the future?

    Thanks again for your support.
    Cheers,
    Jim

  7. Support Staff 5 Posted by Julie on 23 Apr, 2021 08:45 PM

    Julie's Avatar

    Thanks for sharing!

  8. Julie closed this discussion on 23 Apr, 2021 08:45 PM.

  9. Ben Lantow re-opened this discussion on 23 Apr, 2021 09:46 PM

  10. Support Staff 6 Posted by Ben Lantow on 23 Apr, 2021 09:46 PM

    Ben Lantow's Avatar

    Hi,
    I've looked into this more, including testing on my macbook with chrome 90 and I'm still unable to duplicate this issue even using incognito and dumping my entire cache and cookie history. There must be some sort of security settings you opted to set on your machine specifically. With regard to your comment, the changes in chrome are to load a site using HTTPS by default. We've had a HTTPS redirect in place for quite some time so users have been getting a secure connection. (try typing in http://caltopo.com it will redirect to HTTPS).

    We'll dig into those logs in the future, but as far as we are able to tell so far this appears to be an isolated issue.

    Best,
    Ben

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • 2021-04-21_165107.jpg 590 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

14 May, 2021 10:03 PM
14 May, 2021 09:02 PM
14 May, 2021 08:30 PM
14 May, 2021 04:51 PM
14 May, 2021 04:45 PM

 

14 May, 2021 04:24 PM
14 May, 2021 02:11 PM
14 May, 2021 11:38 AM
14 May, 2021 12:11 AM
13 May, 2021 11:52 PM
13 May, 2021 11:24 PM