CalTopo Beta for Android.

Terrence Wilcox's Avatar

Terrence Wilcox

17 Feb, 2019 06:41 AM

I logged in to CalTopo. Now how do I logout so I may change email or servers. I have looked and haven't found a "Log out" or "Sign Out" option.
I can turn it off, using the "Close App" mode, but when I open the App back up, it logs me directly to the map. I even used the computer mode and closed all the open links. (there were two, one to my cell phone) Any other hints or suggestions?

I did find a way to log off when I'm using my computer, but that option does not appear to be on the Android Beta version. Nor does logging off of my computer disconnect my phone from CalTopo

Ok. I just rechecked CalTopo beta for Android, and I'm still logged in. HELP?
Or do I just delete the program and start over?

(PS..why was the other discussion closed without an answer?)


  1. 1 Posted by Terrence Wilcox on 17 Feb, 2019 06:48 AM

    Terrence Wilcox's Avatar

    This time I FOUND IT!!
    Left side, with all the bars. Click on that.
    Go to settings.
    Click on the greyed out ACCOUNT
    My log in appeared and at the bottom, I was able to log out.
    Now I can log back in with my SAR group.

  2. 2 Posted by kobe.pole on 17 Feb, 2019 08:18 PM

    kobe.pole's Avatar

    Hi Terrence, sorry for the delay. Glad you solved it! Let us know if there is anything else we can help you with.

  3. kobe.pole closed this discussion on 17 Feb, 2019 08:18 PM.

  4. dietpepsi9170 re-opened this discussion on 18 Feb, 2019 01:41 AM

  5. 3 Posted by dietpepsi9170 on 18 Feb, 2019 01:41 AM

    dietpepsi9170's Avatar

    Actually, there is.
    For some reason, now that I'm logged out, I still can't log back in using another gmail.
    It want's to sync to my personal gmail.  Perhaps that's the way that gmail works?I know that I can't ever "turn off" my gmail account on my phone....
    Weird!!By the way, the reason that I'd like to use the other gmail is because that is the gmail for our SAR group.
    It's a work in progress and if I can help get the Beta version working for everyone, then it's a good thing

  6. Support Staff 4 Posted by matt on 19 Feb, 2019 04:43 PM

    matt's Avatar

    If you're not signed in to an account, I thought it allows you select which Google account you want to log in with, but regardless: go to, log in to the account you want to log into CalTopo with, and then go to CalTopo and log in.

  7. 5 Posted by dietpepsi9170 on 22 Feb, 2019 04:37 AM

    dietpepsi9170's Avatar

    Sorry for the delayed response, our SAR unit has been busy.Yes, that is the way that the online version works.  Howver, my Android will NOT get past my personal gmail and allow me to go to a Custom server or even a different gmail acccount.  Even whne I log in using my gmail, I can't "sync" to another account.
    Perhaps it's my Samsung phone settings or something that I am doing wrong?Thanks,

  8. Support Staff 6 Posted by matt on 25 Feb, 2019 04:58 AM

    matt's Avatar

    I'm not following when you say you can't get past your personal gmail and go to a different gmail account. Are you saying you're unable to go to via the web and sign in under an alternate account? If so, I don't think that's something I can help you debug. If not, some screenshots or more exact descriptions would help.

  9. 7 Posted by dietpepsi9170 on 26 Feb, 2019 09:47 PM

    dietpepsi9170's Avatar

    We apparently are talking two different subjects.I am talking about the Android phone version, NOT the computer version.
    So, let's start over.  (by the way, I don't answer emails via cell see why later)
    I have the Caltopo app beta version downloaded onto my Samsung cell phone.  I use ATT service.  It came with gmail.  I click on the CT app and open it.
     I get a screen that reads: CalTopo Beta, sign in with a choice of CalTopo or SarTopo.  I select CalTopo and I get a screen that reads: App Activation  Pleasesign in with the account you want to sync: Sign in with Google, More logins....   I select More logins and the screen goes to:
    Sign in with GoogleSign in with YahooSign in with FacebookSign in with Microsoft.If your team uses a custom login server, enter your team alias below: 
    I enter: [email blocked] hit Enter.  The screen goes blank......
    So, I pull up the page info:
    I select "view certificate" just to check:Locked icon  caltopo.comChromium verified that DigiCert SHA2 Secure Server CA issue this website's certificate  (there's more if you need it...but basically it reads that Caltopo is a valid site)
    Still on blank I close Caltopo and start over, except that this time, I select: Sign in with Google.It goes to: App ActivationThis will sync the CalTopo app to your google account [email blocked] by (in blue) Use a different account.  Your device will be synced as: samsung SAMSUNG-SM-G870A
    I select "Use a different account" and it goes right back to:
    Sign in using an alternate account with:Sign in with GoogleSign in with YahooSign in with FacebookSign in with Microsoft.If your team uses a custom login server, enter your team alias below:  ETC.So...I select Sign in with Google and I'm right back where I started
    If I select Sync Account, it goes to
    Successfully synced to account:[email blocked] Mapping.
    here's the thing:  I don't want to sync to my account, I want to sync to the
    "[email blocked]" account

    Unlike the online version, there appears to be no way to add an extra account.Am I doing something wrong?Is it the settings for Gmail on my phone (which doesn't allow me to select the other gmail account because it's apparently assigned to another phone)
    If I have to use my gmail, that means that for SAR purpose, our IMT managers will have to add every single one of us into their database in order to share a map or assignments instead of just being able to place that info onto [email blocked] this make sense?

  10. Support Staff 8 Posted by matt on 26 Feb, 2019 10:18 PM

    matt's Avatar

    You should just be clicking on "sign in through google", not using the custom field. When you do that, it launches a browser window that sends you to Google, Google authenticates you, and then passes you back to the CalTopo app, which closes the window. So even though it's an app, the Google authentication part takes place in a browser window and will use whatever account you're signed into Google with on your phone's web browser.

    If you're signed in to Google using multiple accounts at once, Google with prompt you
    to ask which account you want to use before passing you back to CalTopo. Otherwise, it will send you back automatically without asking if you want to use a different account. That's not something we have any ability to control.

    Open or in your phone's web browser, sign in as [email blocked], and then open the caltopo app and sync it.

  11. 9 Posted by dietpepsi9170 on 27 Feb, 2019 05:10 AM

    dietpepsi9170's Avatar

    Again...MINE doesn't take me to Google, it automatically takes me to App Application and reads "This will sync the CalTopo app to your google account [email blocked]" (use a different account) "Your device will be synced as: samsung SAMSUN-SM-G870A"And if I click into the box labeled "use a different account", it just loops right back to the above

    So....this way doesn't work on my phone/system/server

    So: the second set of directions, worked!  I was able to sign into the second gmail account, bo back to CalTopo and Signin.  This time, there were BOTH sign in's and I chose the Alltracks2019 with sync to my phone and now it reads Start Mapping!  I opened that up, went to top left corner, then Settings, then held down on Account Details, and signed out.I reopened the app and it goes directly to Alltracks2019@gmail which is what we want for SAR application
    When I click on MY gmail icon, I go directly to MY email.

    I think we've got it!!


  12. matt closed this discussion on 05 Mar, 2019 05:39 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

20 Jan, 2022 03:13 AM
20 Jan, 2022 02:54 AM
20 Jan, 2022 01:33 AM
20 Jan, 2022 12:49 AM
19 Jan, 2022 11:22 PM


19 Jan, 2022 10:42 PM
19 Jan, 2022 10:25 PM
19 Jan, 2022 09:17 PM
19 Jan, 2022 04:50 PM
19 Jan, 2022 04:01 PM
19 Jan, 2022 03:36 PM