Forest Service layers named incorrectly

nate.berkopec's Avatar

nate.berkopec

04 Jun, 2018 02:20 PM

Since the latest update, the FS layers have slightly weird/off names. FS2013 appears to be just called "FSTopo" and FS2016 is just "f16a".

Thanks for fixing the area assignment bug though :)

  1. Support Staff 1 Posted by matt on 04 Jun, 2018 09:00 PM

    matt's Avatar

    I think I'm just going to have to ignore this one for a while. I didn't catch it because I didn't have the FSTopo 2016 layer on my offline install, and the difference between "FSTopo" and "FSTopo 2013" is pretty subtle.

    The layer names are coming from the .mbtiles files rather than my code. This will get corrected when I re-release the change that shows more layers by default and fetches tiles from the internet if they're not available locally; until then if you add sarsoft.map.backgrounds=t,f,f16a,etc to sarsoft.properties, it will fix the issue by making the app aware of those layers and pulling metadata from its own properties files rather than the .mbtiles files.

    There is no convenient way to revert back to the old approach of "grab the layer name but no other metadata from the properties file, and everything else from the .mbtiles file".

  2. 2 Posted by nate.berkopec on 05 Jun, 2018 01:18 PM

    nate.berkopec's Avatar

    Specifying sarsoft.map.backgrounds works for me.

    Nate Berkopec
    917 474 6073
    nateberkopec.com <http://www.nateberkopec.com>

  3. matt closed this discussion on 06 Jun, 2018 01:22 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac