I can't get SARTOP offline to open.

tplawman's Avatar

tplawman

10 Nov, 2019 05:38 AM

When I double click on SARTopo-Offline-Java-9-10.bat there is a brief flash (command window?), then nothing happens. Seems like this problem has come up for other users, but those threads are now closed.

Please let me know what I have to do to fix this.

Thanks.

   Tom

  1. Support Staff 1 Posted by Ben Lantow on 11 Nov, 2019 01:20 AM

    Ben Lantow's Avatar

    Hi Tom,
    Would love to help with this, can you give me more information about your system? What operating system are you running? What Java version do you have installed? And what version of the offline SARTopo are you running?

    Best,
    Ben

  2. Ben Lantow closed this discussion on 11 Nov, 2019 01:20 AM.

  3. Ben Lantow re-opened this discussion on 11 Nov, 2019 01:20 AM

  4. 2 Posted by tplawman on 11 Nov, 2019 09:23 PM

    tplawman's Avatar

    Hi Ben,

    I'm running Windows 10 Home Version 1903.

    Java version is: jdk-11.0.5_windows-x64_bin (The version 9 that was referenced in the SARTopo Offline instructions was not on the Java download site.)

    SARTopo version is: SARTopo-Offline-Java-9-10

    Thanks for helping!

    Tom

  5. Support Staff 3 Posted by Ben Lantow on 11 Nov, 2019 09:25 PM

    Ben Lantow's Avatar

    I know it seems counter intuitive. Use the other .bat file that is for 8. The 9-10 bat is only for those two versions.

    Best,
    Ben

    Benjamin Lantow
    Business Operations Manager
    [email blocked]
    847.254.3378

  6. 4 Posted by tplawman on 11 Nov, 2019 11:07 PM

    tplawman's Avatar

    Just tried to open SARTopo-Offline.bat A windows screen comes up about "trying to open an unknown app". I clicked "open anyway". Screen goes away, and then nothing happens.

    If I click on SARTopo-Offline.bat again, a screen flashes, then instantly disappears. Then nothing. Nada.

    Tom

  7. Support Staff 5 Posted by Ben Lantow on 11 Nov, 2019 11:11 PM

    Ben Lantow's Avatar

    Ok. No worries we'll just have to do a little more trouble shooting. Just to ensure you're on the most recent release of the SARTopo product I'm going to have you do two things. First download/update Java (currently JDK 13 is available: https://www.oracle.com/technetwork/java/javase/downloads/jdk13-down...) Update here to the newest version. Then if you have not yet successfully run offline SARTopo you can delete the entire folder that contains the files and re-download from: https://caltopo.com/offline/app?id=B997K1 just to ensure you have the most recent release. At that point lets try the same thing and let me know what happens.

    We'll get it working for you for sure, sometimes this part can be a little fickle.

    Best,
    Ben

  8. Ben Lantow closed this discussion on 11 Nov, 2019 11:11 PM.

  9. Ben Lantow re-opened this discussion on 11 Nov, 2019 11:11 PM

  10. 6 Posted by tplawman on 11 Nov, 2019 11:32 PM

    tplawman's Avatar

    Downloaded and opened Java 13 successfully.

    When I tried to use the link you sent to download SARTopo it says:
    Sorry, something seems to have gone wrong!

    You do not have access to this feature

        * If you think you've reached this page in error, email CalTopo support at [ mailto:[email blocked] | [email blocked] ] .
            * Return to the [ https://caltopo.com/map.html | Map Viewer ] .

  11. Support Staff 7 Posted by Ben Lantow on 11 Nov, 2019 11:42 PM

    Ben Lantow's Avatar

    You have to be logged in to download it. To get there from the home page go
    to the top left corner of the screen with your email account, click on the
    email address and I'm the window that pops up you'll see a tab (last one)
    that says offline access, click the and get the app link.

  12. 8 Posted by tplawman on 12 Nov, 2019 12:10 AM

    tplawman's Avatar

    OK, got it now. Which bat file to open?

  13. Support Staff 9 Posted by Ben Lantow on 12 Nov, 2019 12:16 AM

    Ben Lantow's Avatar

    In theory the Java 8 one

  14. 10 Posted by tplawman on 12 Nov, 2019 12:55 AM

    tplawman's Avatar

    There is no java 8 one. When I unzipped the file, I got "SARTopo-Offline.bat" and SARTopo-Offline-java-9-10.bat"

  15. Support Staff 11 Posted by Ben Lantow on 12 Nov, 2019 12:59 AM

    Ben Lantow's Avatar

    Ah thats right we renamed it for this exact reason. The non 9-10 file.

  16. 12 Posted by tplawman on 12 Nov, 2019 01:33 AM

    tplawman's Avatar

    Exactly the same result as before. Window gives a warning about unknown app. I click "run anyway". Something flashes. Then nothing.

  17. Support Staff 13 Posted by Ben Lantow on 12 Nov, 2019 09:17 PM

    Ben Lantow's Avatar

    Tom,
    Apparently in some newer versions of Java they don't always add themselves to the command path. There are instructions here to add Java to the command path, follow the directions starting at "To set the path variable on Windows"

    https://docs.oracle.com/en/java/javase/12/install/installation-jdk-...

    Then restart the machine and retry starting the .bat file

  18. 14 Posted by tplawman on 14 Nov, 2019 06:12 AM

    tplawman's Avatar

    Did as you said. Still no joy.

    Tom

  19. Support Staff 15 Posted by Ben Lantow on 14 Nov, 2019 06:16 AM

    Ben Lantow's Avatar

    Ok. Next step would be to open a command prompt (Typically, Start, Run, and type cmd). Use cd foldername to move to the folder you have the offline application in. Once in that folder use this exact command.
    java -Dsarsoft.properties=sar.properties -jar sar.jar

    Then send me the output and I'll go from there.

    Best,
    Ben

  20. Support Staff 16 Posted by Ben Lantow on 21 Nov, 2019 06:34 PM

    Ben Lantow's Avatar

    Just following up on this to see if we had you up and running?

  21. 17 Posted by tplawman on 21 Nov, 2019 07:37 PM

    tplawman's Avatar

    Hi Ben,

    Sorry, I haven’t had time to get back to it. Hopefully I can play with it later today.

       Tom

    Sent from my iPhone

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac