USGS tiles not displaying correctly

nate.berkopec's Avatar

nate.berkopec

17 Dec, 2017 05:36 AM

SARTopo Offline v3786. Forest service base layers appear to be working correctly, but the USGS layer looks like it's randomly missing tiles. As an example, map.html#ll=36.43117,-105.53004&z=14&b=t is attached. Redownloading the USGS tiles does not fix the issue.

  1. 1 Posted by nate.berkopec on 17 Dec, 2017 05:47 AM

    nate.berkopec's Avatar

    Forgot to add - this is t-36-105.

  2. 2 Posted by nate.berkopec on 18 Dec, 2017 02:17 AM

    nate.berkopec's Avatar

    Looking at this further, I think it's possible the USGS downloaded tiles are simply not working at all, and the tiles I *am* seeing in the offline app are ones downloaded on-the-fly when the network is working.

  3. Support Staff 3 Posted by matt on 19 Dec, 2017 01:47 AM

    matt's Avatar

    I can verify that the file is good. Basic question, but it's moved into the data/tiles directory?

  4. 4 Posted by nate.berkopec on 19 Dec, 2017 02:32 PM

    nate.berkopec's Avatar

    It is. All of the other downloaded tiles work perfectly - FS2016/2013, all of the other data layers as well. Only having this issue with USGS 7.5.

    Any tips for "fresh installing" SARTopo to make sure I'm working with a clean slate? I've just been deleting the folder containing the "fresh install" stuff, is that enough?

  5. Support Staff 5 Posted by matt on 20 Dec, 2017 03:01 AM

    matt's Avatar

    Topo layers are slightly different than the others, because I wanted the offline version to have one layer that loaded automatically. Just remembered a previous bug related to this, although I thought it was long fixed. In sar.properties (or cal.properties for caltopo offline), can you add the line:

    sarsoft.map.backgrounds=

    And then restart the app?

  6. 6 Posted by nate.berkopec on 20 Dec, 2017 06:16 PM

    nate.berkopec's Avatar

    That fixes the issue, USGS tiles load normally now.

    Nate Berkopec
    917 474 6073
    nateberkopec.com <http://www.nateberkopec.com>

  7. Support Staff 7 Posted by matt on 03 Jan, 2018 05:24 AM

    matt's Avatar

    This has been fixed in the codebase, I'll try to get an updated offline version out soon.

  8. 8 Posted by nate.berkopec on 28 Feb, 2018 03:18 PM

    nate.berkopec's Avatar

    Confirmed fixed in 3898

  9. Support Staff 9 Posted by matt on 28 Feb, 2018 07:59 PM

    matt's Avatar

    thanks

  10. matt closed this discussion on 28 Feb, 2018 07:59 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac