No information of elevation in coordinate list

ritom's Avatar

ritom

04 May, 2018 03:49 PM

Hi!

Why they is in no information of elevation associated to each markers you have created in a map in a coordinate list?

Thanks

  1. Support Staff 1 Posted by matt on 04 May, 2018 06:25 PM

    matt's Avatar

    If you're referring to the "print a coordinate list" option under the print menu, it should show an elevation, but I only have elevation data for the contiguous US and parts of Alaska and Canada, so most non-US locations won't show an elevation.

    If you're referring to something else, can you try describing it differently or include a screenshot?

  2. 2 Posted by ritom on 04 May, 2018 11:18 PM

    ritom's Avatar

    Yes i speak about "print a coordinate list" option under the print menu with a non- US location. But I have the elevation profil when i edit the attributes of a line. So informations are here but not available on the "coordinate list"! This is the same think for ''Measure / Position & Elevation" there are no elevation/Slope/Aspect" informations in the ''Elevation profil'' tool box !

    Thanks

  3. 3 Posted by jkreuzig on 05 May, 2018 12:06 AM

    jkreuzig's Avatar

    I'm noticing the exact same thing. The elevation is showing if I click on the "Position and Elevation", but when I try and print the list, it's not appearing. Is this a premium feature?

    I'm attaching some screenshots of what I'm seeing. FYI, I've tried turning off all the different values, and it's still not there. It appears that there isn't a <tr> entry for elevation in the table that is being output.

    Jim

  4. Support Staff 4 Posted by matt on 05 May, 2018 01:52 AM

    matt's Avatar

    ritom - the small profile dialog pulls elevation data from Google Maps, specifically because they offer global coverage. The large "terrain statistics" profile dialog, along with the elevation shown at the top right of the map, the "position & elevation" dialog and the guide page, uses my own in-house datasource. That's why you see an elevation on the small profile window but not on the guide page.

    Google just revamped pricing for their maps API, and while it will make things significantly more expensive for me, it also seems to no longer limit elevation requests to within their map viewer, so long term it's possible that I could fallback to them when my own data exists, if I don't build out my own global elevation dataset.

    jkreuzig - that's really odd, I dropped a marker with the same symbol in the same location and I'm getting an elevation on the guide page. Elevations are loaded in a separate request - can you look at the console tab for an error, and the network tab (you'll probably have to reload the page with the network tab active) for a request to https://caltopo.com/dem/dem?

  5. 5 Posted by jkreuzig on 05 May, 2018 03:13 AM

    jkreuzig's Avatar

    matt,

    No console or network errors when visiting and reloading https://caltopo.com/dem/dem . I've tried Chrome, Firefox, and Safari. Same thing. I wish I could get errors. At least that gives me somewhere to start looking.

    I tried what you mentioned (drop a marker on that spot) from a blank page with different base layers and then try the "Print a Coordinate List" option. It still doesn't show any elevation. Don't know what's happening.

    Looks like you do have a few mixed content errors (see attached), which happens when you are trying to load unsecure (http) content over a secure (https) connection. However, that doesn't seem to be the problem. I can disable that and still get the same results. It's a few fonts, so it's not a huge problem.

    Wish I could be more help on this. I spend my days working on stuff like this (databases, systems admin, websites, etc.) and it's frustrating to not be able to come up with an answer.

    Thanks again for the great product.

    Jim

  6. 6 Posted by jkreuzig on 05 May, 2018 03:23 AM

    jkreuzig's Avatar

    Wait, when reloading the guide page with the console open, I'm getting a type error in the console:

    TypeError: config.units is undefined ... https://caltopo.com/guide:120:6

    the guide code section it reference is this:

    dem.getElevationForLocations(locations, function(data) {
        var metric = config.units.indexOf("metric") == 0;
        for(var i = 0; i < data.length; i++) {
            var id = locations[i].id;
            $('#mw' + id).find('tbody').append('<tr class="mele"><td style="padding-right: 0.5em">ELE</td><td>' + Math.round(data[i].elevation * (metric ? 1 : 3.2808399)) + (metric ? 'm' : '\'') + '</td></tr>');
        }
    }
    

    Don't know if that helps.

    Jim

  7. 7 Posted by jkreuzig on 05 May, 2018 03:28 AM

    jkreuzig's Avatar

    Dam, I need to go home. If I set the "Coordinates -> Units" in the Config menu to a single value, it works. If it's set to "Mixed", it doesn't print anything out.

    Lesson here: CHOOSE YOUR COORDINATE SYSTEM JIM!

    LOL.

    Jim

  8. ritom closed this discussion on 06 May, 2018 10:38 PM.

  9. matt re-opened this discussion on 07 May, 2018 03:41 AM

  10. Support Staff 8 Posted by matt on 07 May, 2018 03:41 AM

    matt's Avatar

    This was a recently introduced bug that only appeared if you hadn't changed the config menu options. It's fixed now.

  11. matt closed this discussion on 07 May, 2018 03:41 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac