GPSIO and Garmin Fenix Watch

GOB's Avatar

GOB

20 Nov, 2020 03:48 PM

Should I be able to import/export to the Garmin Fenix 5x Plus via the GPSIO function?
I have:
installed GPSBabel correctly
installed the GPSIO program via python correctly (it found GPSBabel and reported successful install)
installed chrome extension for GPSIO (the one that only works with caltopo)
installed the Garmin drivers

Tried with watch plugged in via USB and not plugged in.

When I click on import via GPSIO, I get "no GPS found" in red.

Thanks!

  1. Support Staff 1 Posted by Meghan on 20 Nov, 2020 06:45 PM

    Meghan's Avatar

    I believe the Garmin Fenix 5 series supports a USB mass storage interface. A list of Garmin devices with USB mass storage as the default setting can be found here: Mass Storage Garmin Outdoor Devices. You should be able to plug the GPS into your computer, it will appear as a USB drive, like a thumb drive or external hard drive. More information on using the USB Mass Storage interface method can be found here: Working with GPS Units.

    Hope that helps!
    Meghan

  2. Meghan closed this discussion on 20 Nov, 2020 06:45 PM.

  3. caver456 re-opened this discussion on 20 Nov, 2020 07:14 PM

  4. 2 Posted by caver456 on 20 Nov, 2020 07:14 PM

    caver456's Avatar

    Also FYI - for mass storage devices, GSPIO is really just a 'wrapper'
    around the normal file access as on any other thumb drive. Behind the
    scenes, GPSIO just reads/writes the file as if you were navigating to it.
    GPSIO can potentially save a few clicks and a few seconds depending on
    who's using it, but certainly isn't the only way. For non-mass-storage GPS
    devices, or ones that require you to jump through some hoops to turn them
    into mass storage devices, like the 60, GPSIO automatically detects this
    and uses Garmin's serial interface instead.

    If you do want to diagnose GPSIO, the first step is to make sure you have
    the GPSIO extension icon at the top right of your browser (a blue and gray
    squashed cartoon GPS). Left click it, and it should tell you 'Plugin
    working properly'. If that is all good, then, it's possible the USB device
    hadn't yet been recognized by Windows (or Mac?) by the time GPSIO tried to
    talk to it - wait til it shows up as a thumb drive, then try again.

  5. 3 Posted by GOB on 20 Nov, 2020 08:35 PM

    GOB's Avatar

    In settings, you can change the fenix USB mode to “Garmin” - would this do it?

  6. Support Staff 4 Posted by Ben Lantow on 20 Nov, 2020 08:58 PM

    Ben Lantow's Avatar

    The absolute fastest easiest way to get data off the Garmin watches is to just download the data you're syncing out of Garmin Connect, if you already have all the sync stuff set up on a Fenix, all the tracks are automatically uploaded to the cloud. No configuration changes needed. Then you can just download and import the track. You can also do so by connecting the device to the computer directly and browsing like any other USB mass storage device.

    Best,
    Ben

  7. 5 Posted by caver456 on 20 Nov, 2020 09:02 PM

    caver456's Avatar

    Not sure - I don't have a recent Garmin to look at right now, but I think
    the choices are generally USB-mass-storage or Garmin-Serial.
    USB-mass-storage is what you want to have it recognized just like a thumb
    drive. Garmin Serial is default for old-style (like the 60), not sure if
    Garmin Serial is even an option for newer models, I think they may just be
    USB-mass-storage always.

  8. 6 Posted by GOB on 20 Nov, 2020 10:03 PM

    GOB's Avatar

    Ben - yes, but you can’t do that on the phone (can’t download gpx from the watch on the app).

  9. Support Staff 7 Posted by Ben Lantow on 24 Nov, 2020 01:14 AM

    Ben Lantow's Avatar

    Correct you can always just plug the watch in directly and copy tracks off of it as a mass storage device, no GPSIO is needed.

    Best,
    Ben

  10. Ben Lantow closed this discussion on 24 Nov, 2020 01:14 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac