Duplicate blank maps being created...

dan.dawson's Avatar

dan.dawson

06 Jan, 2021 05:45 PM

Something new popped up yesterday that we've never seen before... the report from a team member was:

"When Chris set up a team map yesterday from his mobile app, it looks like Caltopo created a map every three minutes for our entire ride from about 1:00 pm to 5:00 pm. See screen shot below - I assume you can see these in the team map folder also."

And I agree, when I look at our Team Maps folder I see just over 100 maps titled "N/A" ...and the few I checked were completely empty.

Any idea what might have triggered something like this to occur?

  1. Support Staff 1 Posted by Julie on 06 Jan, 2021 06:33 PM

    Julie's Avatar

    Well, that is not a useful occurrence. Goodness.

    Questions:
    1. What level within the team account does the user have? What device and app version is he using?
    2. Was he in poor network service?
    3. Anything else you or he can think of to tell us? This is certainly something we want to figure out and prevent in the future.

    Thanks,
    Julie

  2. 2 Posted by dan.dawson on 06 Jan, 2021 07:00 PM

    dan.dawson's Avatar

    > 1. What level within the team account does the user have?

    He has Write access on the team account.

    > What device and app version is he using?

    iPhone 8 with iOS 14.2. CalTopo version 0.6.12.

    > 2. Was he in poor network service?

    Yes, I believe he was out on the trail or at the trailhead.

    > 3. Anything else you or he can think of to tell us?

    Not that I'm aware of.

    I wasn't sure if your team needed to take a look at the extra maps, so I'll leave them for an hour or two and then delete all of the excess ones.

    Thanks!

  3. 3 Posted by dan.dawson on 06 Jan, 2021 07:21 PM

    dan.dawson's Avatar

    Here is the additional info I got from their Team Lead:

    > We had decent cell service initially at Kapka and up to Dutchman. After Chris created the map, I uploaded a GeoJson file to one version of it with all the snowmobile trails. It populated across everyone's phones just fine, and we also each recorded our tracks (four total) that we were able to use throughout the ride.
    > I can't tell which of the map versions we actually used on Sartopo online, but it was I think the second oldest time stamped version on the mobile app. When I open them now, none have map items, so not sure if the version we used still exists.
    >
    > Some anomalies that Caltopo might look into ...
    > -- looks like Chris did not name the map, not sure if this triggered some sort of loop.
    > -- Chris recorded tracks, and may have started recording tracks to a different non-team map before he closed that other map and then created the team map. Perhaps the order of entries triggered a loop.

  4. Support Staff 4 Posted by Julie on 06 Jan, 2021 07:32 PM

    Julie's Avatar

    Thank you Dan! I'll pass this along to the team and see what we can find.

  5. 5 Posted by caver456 on 09 Jan, 2021 01:57 PM

    caver456's Avatar
  6. 6 Posted by caver456 on 09 Jan, 2021 02:09 PM

    caver456's Avatar

    A few days before the search, I made a map called test2, while logged in as
    myself (this email address). I saved the map to the team account. After
    the test, I promptly deleted the map.

    Then last night during a call, test2 showed up in the app, along with
    duplicates that kept creating themselves for a time.

    For reference, I probably started my app for the first time a few minutes
    after the call which happened at 6:17pm.
    I wasn't able to determine any pattern, but it seemed like the test2
    entries didn't start creating themselves until I opened the app. I did
    restart the app several times to try and get the list of maps to refresh
    since the expected map for the actual search wasn't on the list yet and the
    spinner doesn't seem to do the trick (it just keeps spinning for a long
    time with no visual change to the list, even when we know for a fact that a
    new team map has been created and it's visible from other computers and
    phones - that's not new behavior, but is a tangent for this thread). Not
    sure if those app restarts are related, I don't think they are, but it's
    possible that a new map was created each time I restarted the app - but I
    did not get that impression.

    Anyway, other folks were also seeing the duplicate maps on their apps, and
    on a computer. But they showed up for different folks at different times -
    that's also probably unrelated.

    Aha! I just restarted the app now and it created another duplicate!
    6:07am. Email from phone with screenshot to follow.

    I've asked folks to leave the maps in our team account for at least a few
    days.

  7. 7 Posted by caver456 on 09 Jan, 2021 02:11 PM

    caver456's Avatar

    On Sat, Jan 9, 2021, 6:09 AM Tom Grundy <[email blocked]> wrote:
    A few days before the search, I made a map called test2, while logged in as myself (this email address).  I saved the map to the team account.  After the test, I promptly deleted the map.

    Then last night during a call, test2 showed up in the app, along with duplicates that kept creating themselves for a time.

    For reference, I probably started my app for the first time a few minutes after the call which happened at 6:17pm.  
    I wasn't able to determine any pattern, but it seemed like the test2 entries didn't start creating themselves until I opened the app.  I did restart the app several times to try and get the list of maps to refresh since the expected map for the actual search wasn't on the list yet and the spinner doesn't seem to do the trick (it just keeps spinning for a long time with no visual change to the list, even when we know for a fact that a new team map has been created and it's visible from other computers and phones - that's not new behavior, but is a tangent for this thread).  Not sure if those app restarts are related, I don't think they are, but it's possible that a new map was created each time I restarted the app - but I did not get that impression.

    Anyway, other folks were also seeing the duplicate maps on their apps, and on a computer.  But they showed up for different folks at different times - that's also probably unrelated.

    Aha!  I just restarted the app now and it created another duplicate!  6:07am.  Email from phone with screenshot to follow.

    I've asked folks to leave the maps in our team account for at least a few days.

    On Sat, Jan 9, 2021 at 5:57 AM Tom Grundy <[email blocked]> wrote:
    So we just noticed this last night during a call.  Several android app 0.6.11 screenshots below.  More details in separate email to follow from real keyboard.

    On Wed, Jan 6, 2021, 11:32 AM Julie <[email blocked]> wrote:

    // Please reply above this line
    ==================================================

    From: Julie (Support staff)

    Thank you Dan! I'll pass this along to the team and see what we can find.

    On Wed, Jan 06 at 11:21 AM PST, dan.dawson wrote:

    Here is the additional info I got from their Team Lead:

    > We had decent cell service initially at Kapka and up to Dutchman. After Chris created the map, I uploaded a GeoJson file to one version of it with all the snowmobile trails. It populated across everyone's phones just fine, and we also each recorded our tracks (four total) that we were able to use throughout the ride.
    > I can't tell which of the map versions we actually used on Sartopo online, but it was I think the second oldest time stamped version on the mobile app. When I open them now, none have map items, so not sure if the version we used still exists.
    >
    > Some anomalies that Caltopo might look into ...
    > -- looks like Chris did not name the map, not sure if this triggered some sort of loop.
    > -- Chris recorded tracks, and may have started recording tracks to a different non-team map before he closed that other map and then created the team map. Perhaps the order of entries triggered a loop.

    Having trouble reading this? View this discussion online: Duplicate blank maps being created....

    To unsubscribe and stop receiving emails from http://help.caltopo.com, visit this page

  8. 8 Posted by caver456 on 09 Jan, 2021 02:13 PM

    caver456's Avatar

    also - we were in good cell service the whole time - we never left the
    station; I initially made the test from home and am now at home - 4 bars 4G
    Verizon.

  9. 9 Posted by Stephen on 09 Jan, 2021 10:20 PM

    Stephen's Avatar

    We, Santa Barbara SAR started experiencing this today.

  10. Support Staff 10 Posted by Ben Lantow on 10 Jan, 2021 03:10 PM

    Ben Lantow's Avatar

    We'll fix this ASAP - thanks for the bug report.

    Ben

  11. 11 Posted by mvbanks on 11 Jan, 2021 04:03 PM

    mvbanks's Avatar

    We also ran into this problem on a mission Saturday and I have deleted over 50 blank, app generated maps labeled as N/A. We were in an area with intermittent cell service when a map was created on a users phone with update privileges. Now that she is home and in good coverage area, if she tries to open the app, a new blank map is created on the team account. We have a 25 user team account.

  12. 12 Posted by mvbanks on 11 Jan, 2021 04:19 PM

    mvbanks's Avatar

    Our user is on an Iphone 7+ and is running 6.12

  13. Support Staff 13 Posted by matt on 12 Jan, 2021 01:32 AM

    matt's Avatar

    Hi All -

    Sorry about this one. The latest version of the desktop app requires a login to sartopo.com, which simplifies our codebase considerably since we can assume there's always a logged in user. I took advantage of this to clean up a bunch of cruft, and in the process altered a permissions check that used to only run on sartopo.com, to run on the app / desktop version as well.

    The result is that this happens when an UPDATE or WRITE level user saves a new map to the team account. The app initially creates a local map with a 3 digit ID, then syncs that map to sartopo.com when cell reception is available, and finally cleans up the old 3-digit map. Because the 3-digit map belongs to the team, the user doesn't have manage access, and I caused the permission check to be run everywhere, the app won't delete the 3-digit map after syncing, and keeps trying to re-sync it.

    I think all of our testers have admin access on our test team account, that's clearly something we need to adjust for future testing.

    I'll get a new app built tonight or tomorrow morning, but it will likely be Wed before it's available for download. In the meantime, you'll need to have MANAGE or ADMIN users create team maps in the app to avoid this.

    • Matt
  14. 14 Posted by mvbanks on 12 Jan, 2021 03:33 AM

    mvbanks's Avatar

    No worries
    Glad you’re able to fix it.
    We are getting spoiled.
    MB

  15. Meghan closed this discussion on 13 Jan, 2021 03:19 PM.

  16. caver456 re-opened this discussion on 13 Jan, 2021 07:11 PM

  17. 15 Posted by caver456 on 13 Jan, 2021 07:11 PM

    caver456's Avatar

    Thanks Matt - can you confirm that if we get everyone to update their app
    today, that the issue is resolved and we can delete the blank maps from our
    team accounts?

  18. Support Staff 16 Posted by Ben Lantow on 13 Jan, 2021 07:49 PM

    Ben Lantow's Avatar

    You're welcome to delete any blank maps. However the app update is only released to beta testers so far not to production yet, need to ensure there's no issues before release. The bug that we did have appears to be appropriately fixed in the next app release however.

    Best,
    Ben

  19. 17 Posted by caver456 on 13 Jan, 2021 08:09 PM

    caver456's Avatar

    sounds good, thanks.

  20. Support Staff 18 Posted by Julie on 14 Jan, 2021 07:50 PM

    Julie's Avatar

    The fix is fully released now, so please have everyone on your teams make sure they update the app.

  21. Julie closed this discussion on 14 Jan, 2021 07:50 PM.

  22. caver456 re-opened this discussion on 14 Jan, 2021 07:57 PM

  23. 19 Posted by caver456 on 14 Jan, 2021 07:57 PM

    caver456's Avatar

    great, thanks all!

  24. Support Staff 20 Posted by Julie on 14 Jan, 2021 08:23 PM

    Julie's Avatar

    Well it turns out I was mistaken - it's slowly releasing over the next few days. If the user is on iOS, they can manually get the latest from the App Store, but for Android there's no such work around. It will be available to everyone within the next several days.

  25. Julie closed this discussion on 14 Jan, 2021 08:23 PM.

  26. caver456 re-opened this discussion on 14 Jan, 2021 09:22 PM

  27. 21 Posted by caver456 on 14 Jan, 2021 09:22 PM

    caver456's Avatar

    got it, thanks

  28. 22 Posted by mvbanks on 14 Jan, 2021 11:09 PM

    mvbanks's Avatar

    Is the fixed IOS version 0.6.14?

  29. Support Staff 23 Posted by matt on 15 Jan, 2021 12:05 AM

    matt's Avatar

    Yes

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • Screen_Shot_2021-01-06_at_9.38.46_AM.png 725 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

23 Apr, 2021 03:59 AM
23 Apr, 2021 03:47 AM
23 Apr, 2021 12:45 AM
23 Apr, 2021 12:13 AM
22 Apr, 2021 11:40 PM

 

22 Apr, 2021 11:36 PM
22 Apr, 2021 08:48 PM
22 Apr, 2021 06:14 PM
22 Apr, 2021 05:50 PM
22 Apr, 2021 04:20 PM
22 Apr, 2021 03:55 PM