Print to PDF creates web page with map but no controls

Ivars Finvers's Avatar

Ivars Finvers

08 Aug, 2020 04:29 PM

Hi,

When I try to print a map using the "Print to PDF" print menu, a new browser tab opens with the map but no controls are visible except a Map Layers button (which doesn't work), the coordinates box, and the +/- controls. I don't see the printing options menu along the left side as expected.

I've tried this with Safari, Firefox, and Chrome. All behave the same.

I have a Basic Subscriptions.

Am I missing something or is this a bug?

Thanks.

  1. 1 Posted by Tom Berquist on 08 Aug, 2020 07:39 PM

    Tom Berquist's Avatar

    I have the same problem. When Print PDF or JPG is clicked, a full screen map shows up in a new tab but the controls for scale etc and the red rectangle don't show up. I use Chrome and this function has always worked in the past.

  2. 2 Posted by caver456 on 08 Aug, 2020 07:59 PM

    caver456's Avatar

    Hi Tom and Ivars - this is not a bug - this is the expected behavior.
    "Print" in caltopo generally means "Create a new image file - pdf or jpg -
    and open it in a new browser tab." The new browser tab is just viewing the
    generated image, nothing else, and therefore has no controls or buttons.
    Notice the new URL in the new browser tab - .../p/1234 or something like
    that. This is the URL of your generated image. After that, it's up to the
    browser to send it to your printer - in Chrome, that generally means
    hovering around the upper right of the generated image until you get a
    print icon, or hitting Ctrl-P.

  3. 3 Posted by Tom B on 08 Aug, 2020 09:12 PM

    Tom B's Avatar

    Thank you for your reply. I'm trying to create a map with a specific scale
    (eg 1:24000). I've created several maps with different scales in the past.
    I would like to do this with the map I am now working on. Eventually, I
    want a JPG map to include in an electronic document. I don't want a hard
    copy at this time.

  4. 4 Posted by Ivars Finvers on 08 Aug, 2020 09:26 PM

    Ivars Finvers's Avatar

    Thanks for the replies. If I go to the help page for printing, the screenshot show a region on the left hand side of the map that allows options to be set for the printed map.

    https://help.caltopo.com/kb/printing/printing

    It is unclear to be how I can access these options for printing.

    Ivars

  5. 5 Posted by caver456 on 08 Aug, 2020 09:37 PM

    caver456's Avatar

    Following the sequence of pictures on that page you reference - if you hit
    'print to pdf or jpg' from the Print banner menu on the main map page, and
    it doesn't open a new browser tab as indicated, then yes that is a bug, but
    it seems more likely that we're just miscommunicating. What happens when
    you do as indicated on that web page, copied below?

    Printing

    CalTopo can print using most map layers; Google's layers (e.g. satellite)
    are not available due to licensing issues.

    To start, select *Print to PDF or JPG* from the *Print* menu at the top of
    the screen.

    [image: print-1.png]

    This will open a print page in a new browser tab.

    [image: print-2.png]

  6. 6 Posted by Tom B on 08 Aug, 2020 09:44 PM

    Tom B's Avatar

    When I click "Print to PDF or JPG" a new browser tab is opened with a full
    screen map. However, the side-bar with Print Size, Scale, Format, Grid
    Lines etc and the Red Rectangle superimposed over the map do not show up.

  7. 7 Posted by caver456 on 08 Aug, 2020 09:51 PM

    caver456's Avatar

    Looks like I spoke to soon - apologies. I also see similar problems,
    running Chrome on Windows - the print interface page opens in a new tab as
    expected, and for me the left bar with options does appear as expected, but
    the basemap layer is set to 'No Name' and the map area is all gray - the
    red corner arrows and center dot appear, but not the red rectangle. If I
    change the basemap layer to something else, then the map looks good and the
    red rectangle appears. This is repeatable, i.e. close that tab, then do
    Print to PDF or JPG again, and the same behavior happens in the newly
    opened print interface tab. Can you change the basemap layer, and if so,
    does it change other parts of the print interface? Does seem like this is
    a bug. I'm just another user, not on the help staff.

  8. 8 Posted by Tom B on 08 Aug, 2020 10:43 PM

    Tom B's Avatar

    I appreciate the time you've put into this.
    I tried four different basemap layers and all resulted in the same issue I
    described above.
    Seems like a bug to me. I've created 31 different maps and never had a
    problem.

  9. 9 Posted by caver456 on 08 Aug, 2020 10:53 PM

    caver456's Avatar

    Yeah it is odd. Just to clarify, I'm effectively signing off from this
    thread now - the paid help staff will be picking it up very soon no doubt.

  10. 10 Posted by Tom B on 09 Aug, 2020 03:20 PM

    Tom B's Avatar

    Just discovered that if I log out of my account, the Print to PDF or JPG works like it is supposed to. Only problem is that I need access to the maps I have stored in my account.

  11. Support Staff 11 Posted by matt on 10 Aug, 2020 04:02 PM

    matt's Avatar

    Tom / Ivars -

    I think I can reproduce if I turn one of the checkbox data layers (NWS forecast grid, shared caltopo maps, etc) on. I'll fix that, but in the meantime can you confirm that printing works fine if you ensure those layers are unchecked?

    I can also reproduce a softer version of the issue if I print with a Google layer as the basemap (sidebar and corner drag handles show up but the rectangle doesn't, fixable by choosing a new layer on the printing page).

    • Matt
  12. 12 Posted by caver456 on 10 Aug, 2020 04:07 PM

    caver456's Avatar

    (this is Tom G)

    I see the same behavior as Matt.

  13. 13 Posted by Tom B on 10 Aug, 2020 06:00 PM

    Tom B's Avatar

    Matt,

    I had the SnoTel box checked. When I unchecked it, printing seemed to work
    fine on Map Builder. I saw the same issue you mentioned above with Google
    Map and Google Terrain.

    Tom

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac