Map keeps crashing when I try to add a new line to an existing map

Emily's Avatar


21 Jul, 2020 05:23 AM

Hi there, I am trying to add an alternative route to an existing saved map on my account and every time I add a new line and then go to move the map to continue drawing, it crashes the map and goes back to my account start page. First noticed it happening about 2 weeks ago and I have gotten it to work once or twice...but not consistently.

  1. Support Staff 1 Posted by Julie on 21 Jul, 2020 04:25 PM

    Julie's Avatar

    Hi Emily,

    Can you tell me more about what you are seeing here? First of all, are you using the web browser or are you in the app on your phone? For browser, please tell us which one. For the phone, please tell us what device and what app version you are using. Have you tried logging out and back in again? Does this happen always on the same map, or on different saved maps? Especially if it's only on one map, can you send us the map ID? Are you using special line types (arrows or dots or something)? Are there a lot of other objects on the map already? What base layer are you using? Does this happen when adding other types of objects, or only with lines?


  2. 2 Posted by Emily Heard on 21 Jul, 2020 05:28 PM

    Emily Heard's Avatar

    Hi Julie,

    I am using the Chrome web browser, and logging in with my Google account. I have tried logging out and logging in, and cycling back and forth to the home page (on the offchance that going directly to the map URL is the wonky bit). It has happened on multiple maps. It has happened when I start a new map, but mostly just on existing saved maps. The map I am currently working on is here,<> and has about 7 lines and 6 points, so not a huge map. Using the basic map builder topo. I haven't tried adding much else. I've been mostly just trying to plot alternative routes to see if I can break the days up a little easier, and haven't gotten beyond that since it keeps resetting.
    Dusy Basin<>



  3. Support Staff 3 Posted by Ben Lantow on 21 Jul, 2020 07:05 PM

    Ben Lantow's Avatar

    When you say "crashes the map" can you tell me what that means to you? What happens on the screen? What version of chrome? What operating system?

    This is the only time I've heard of anything like this and I'm at a bit of a loss of what could be causing it.

    Can you also go to the 3 dot menu on the far right side of the screen, more tools, developer tools, and report back if there are any errors in the "console" tab.


  4. 4 Posted by Emily Heard on 21 Jul, 2020 08:31 PM

    Emily Heard's Avatar

    Hi Ben,

    It freezes and then resets to the home map screen, as if I hadn't been editing any map at all. I'm still logged in, but all the editing I had done is gone and I have to go back and reopen the map.

    Chrome: Version 83.0.4103.106 (Official Build) (64-bit)
    Windows. I have had it on both my work and home computers.

    Here are the most recent errors.

    I also just went back to the map to see how it resets - it resets in the same general location. And it gave me a read only warning on the map and asked for password...even though it is my map. When I logged out and in again, it went away but the original error is still there.



  5. Support Staff 5 Posted by matt on 27 Jul, 2020 03:00 PM

    matt's Avatar

    Hi Emily -

    Sorry for the delayed reply on this. I'm curious to see what the additional errors are if you scroll up in the developer console window, but all those messages appear to be from browser extensions - we've occasionally had issues with poorly-written browser extensions interfering with the site.

    Can you try editing the map with your browser extensions disabled (and send another screenshot of the console if you still have issues)? The simplest way to do this is to use the site in a Chrome incognito window (file -> new incognito window), which disables browser extensions unless you've specifically authorized them to be used in incognito mode.

    • Matt
  6. 6 Posted by Emily Heard on 28 Jul, 2020 06:36 PM

    Emily Heard's Avatar

    Sure. I opened it in incognito mode and made sure to turn off the adblocker (which still shows up in incognito). It still did the same thing.

    Start editing fine, edit within the open window fine, move to a different part of the map to continue editing reset the map. Here was the only error, which only showed up when I changed the console view to "verbose"




  7. Support Staff 7 Posted by matt on 29 Jul, 2020 04:33 PM

    matt's Avatar

    Sorry this is happening. Those messages at the verbose level are normal - I was really hoping it would be tied to a browser extension. This is the first time I've run into this issue and I don't have any immediate insight. I'd like to continue trying to debug it, although I totally understand if you feel like you have better things to do with your time than work on this with us, so don't feel obliged to keep trying things.

    Can you describe what you're doing in as much detail as possible? Are you drawing the new line freehand, or snapping to trails? How zoomed in on the map are you? Are you panning the map just one screen width, or more? And when you say it crashes the map and goes back to your account start page, what do you mean by that - does it go to the /map.html map viewer, or some other page?

  8. 8 Posted by Emily Heard on 29 Jul, 2020 05:17 PM

    Emily Heard's Avatar

    No big. It is pretty consistent.

    I log in,
    Go to my saved maps,
    select the saved map I'm working with (it has done it with all of them and new ones though), The one I've working on most recently is this one.
    right click and select new line (or extend, it doesn't seem to super matter)
    Zoom in pretty close to try and select a trail so it snaps.
    Select the Trail to start the line
    Select another point on the trail to continue the line
    Reach the end of my extent,
    Click and grab to move the map extent - I am usually just working along a trail and snapping, so I usually move just enough to keep the line snapped and visible to me.
    Site resets to either my initial map view or the whole country

    The key part it is when I go to reset the extent to continue editing, that is where it (almost) always crashes/resets. I assume because the page is having to load new information. I have successfully edited them periodically, which makes me wonder if it is a network connection issue (ours or yours, who knows).
    I do frequently have Chrome, and Caltopo, loaded on multiple computers, as I switch between my work and my home computer, but one is almost always in standby when the other is being used.



  9. Support Staff 9 Posted by matt on 29 Jul, 2020 05:38 PM

    matt's Avatar

    Thanks. When you say:

    Site resets to either my initial map view or the whole country

    Is the URL still /m/SRF0, or does it reset to /map.html? And are your lines/markers still visible, or do they disappear?

  10. 10 Posted by Emily Heard on 29 Jul, 2020 05:54 PM

    Emily Heard's Avatar

    The extent it resets to seems to depend. I just did it again, and it reset to another part of the Sierra that I was just looking at earlier today (Courtright Reservoir). Even though I went my SRFO Dusy Basin map first. When it resets to the map, the existing saved lines are still there but not the lines I was actively editing.

    And then I did it again, and it reset me to Courtright Reservoir again, but at a different extent.



  11. 11 Posted by Emily Heard on 29 Jul, 2020 06:02 PM

    Emily Heard's Avatar

    After (and now yet a different extent than the two I just got, but still generally close to Courtright Reservoir):



Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac