iOS app - 40' contours not available offline

nate.solnit's Avatar

nate.solnit

27 Jun, 2020 08:23 PM

Overall really enjoying the app and offline use overall, but the download tiles function does not include the highest resolution MapBuilder layer (40' contours). They are available online, show availability for download, and will even store in the cached tiles for offline use, but I would really like to keep them reliably downloaded.

It seems related to a bug mentioned in a closed discussion, see response 8, but I'm not sure if the bug was resolved.
https://help.caltopo.com/discussions/android/30-resolution

My current workaround is to trace my route zoomed in to the highest resolution before leaving cell service to cache as many tiles as possible, but it's pretty clunky. I'd love to figure out a better solution.

For reference I am in the Anchorage AK area and, use iOS 13.4.1 and CalTopo v0.5.6.

  1. Support Staff 1 Posted by Ben Lantow on 29 Jun, 2020 04:59 AM

    Ben Lantow's Avatar

    HI,
    I think there are a couple concepts being confounded here I'll do my best to explain.

    You are mixing up the Map Builder Topo layers and the Contour overlay. The Basic subscription includes standard resolution Map Builder Topo (4m resolution) there is a Contour overlay that is completely separate. I see 40ft contours on several zoom levels of my downloaded Map Builder Topo, there are also layers with contours that show up at 200ft, the contour lines are based on the zoom level. If you want higher zoom levels you would need to upgrade your subscription and download the higher resolution tiles.

    The reference you pasted here refers specifically to the contour overlay, not to the Map Builder Topo tiles.

    The use you describe of trying to cache cells is not supported, and is a circumvention of the subscription levels and offerings which is unreliable typically.

    Best,
    Ben

  2. Ben Lantow closed this discussion on 29 Jun, 2020 04:59 AM.

  3. nate.solnit re-opened this discussion on 29 Jun, 2020 05:29 PM

  4. 2 Posted by nate.solnit on 29 Jun, 2020 05:29 PM

    nate.solnit's Avatar

    Thanks for the reply Ben.

    Just to clarify, the layers of the Map Builder Topo / Hybrid Map Builder that show 40’ contours are not available for download with the basic subscription? The pro subscription includes “high resolution … maps” for download (the 2m resolution version) if I understand correctly. Is this the layer you need to see 40’ contours? My gut tells me that a 4m resolution is easily high enough to show 40’ vertical resolution.

    I’m a little frustrated if that’s the case, being limited to 200’ contours kills a lot of functionality for me and would put the app behind your competition at that price point.

    I was thinking it might be an issue with my slightly older phone (iPhone SE ~2018) or my iOS version.

  5. Support Staff 3 Posted by Ben Lantow on 29 Jun, 2020 05:48 PM

    Ben Lantow's Avatar

    Sorry that is not quite correct. 4m resolution has 40' contours at several zoom levels, 40' Contour intervals appear on Map Builder Topo at Zoom 15 and higher.

    Best,
    Ben

  6. Ben Lantow closed this discussion on 29 Jun, 2020 05:48 PM.

  7. nate.solnit re-opened this discussion on 29 Jun, 2020 07:11 PM

  8. 4 Posted by nate.solnit on 29 Jun, 2020 07:11 PM

    nate.solnit's Avatar

    Understood. I was confused about some of the terminology.

    The only concern I have is that when offline and zoomed in, the 40’ contours do not auto-populate. I have attached two screen shots to illustrate, one in airplane mode, and one online at similar zooms.

    1. Is this a subscription limitation or a software / hardware issue?
    2. If it’s a subscription limitation, what subscription level would allow offline access to the zoom levels that show 40’ contours?

  9. Support Staff 5 Posted by Meghan on 29 Jun, 2020 10:13 PM

    Meghan's Avatar

    Hi,

    You should be able to view 40' contours at zoom 15 or higher on the downloaded 4 m resolution MapBuilder Topo. Attached is a screenshot from my phone in airplane mode with MapBuilder Topo map tiles downloaded at the standard (4m) resolution. This resolution is available for download with a basic subscription. Did you download the map layers before you went into airplane mode?

    Best,
    Meghan

  10. 6 Posted by nate.solnit on 29 Jun, 2020 10:55 PM

    nate.solnit's Avatar

    Hi Meghan,

    I downloaded everything available for the region, including the higher res elevation data. Occasionally random tiles will load 40’ contours, I will attach a screen shot. I believe this is caused by the cache system. I cannot reliably get area coverage offline. Once I reconnect to the internet the detailed layer (40’ contours) will fill in.

    I have tried clearing all the downloads and cache and re-downloading, using the other elevation data. Everything else seems to download / display in its entirety. As I said before I have an old iPhone SE, not exactly state of the art, could that be causing problems?

    I also don’t know how to tell exactly what zoom level I am at, but as shown in the screenshot it seems like it should load the detailed contours across the area.

  11. Support Staff 7 Posted by Meghan on 30 Jun, 2020 09:14 PM

    Meghan's Avatar

    Thanks for taking the time to provide the screenshots and detailed steps of what you did/tried- it is really helpful for figuring out what is going on. I was able to reproduce what you were describing in that particular area on my iPhone 8 but not in any other area I had downloaded. It seems like there may be some bad MapBuilder tiles in that area so I have logged it on the development board to be addressed.

    To facilitate tracking requests and duplicates, I am going to close this ticket, but be assured we're working on it! If another user has the same or similar issue, please comment here to reopen the thread.

    Thank you again for taking the time to provide the detailed feedback!
    Best,
    Meghan

  12. Meghan closed this discussion on 30 Jun, 2020 09:14 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac