APRS TNC Setup - offline SARTopo

r70's Avatar

r70

31 May, 2020 07:41 PM

Hi
I am trying to set up a TNC connection with a Kenwood TM-D710G. When I include the following lines in my sar.properties file... (as outlined here - https://help.caltopo.com/kb/objects/aprs-objects )

sarsoft.location.aprs.local.enabled=true
sarsoft.location.serial.COM3=1200,8,1,0

The command prompt window pops up and starts to run Java but then errors out very quickly and closes the command window. When these lines are not in my sar.properties file then offline sartopo runs fine. It's actually sarsoft.location.aprs.local.enabled=true that seems to cause java to crash.

I just downloaded Offline SARTopo and Java on 5/30/20 as per https://help.caltopo.com/kb/caltopo-desktop-formerly-offline/installing-and-running-the-caltopo-desktop-app-windows. so the versions should be the latest. I am running Win 10 Home. A crash log is attached.

Jim

  1. Support Staff 1 Posted by Ben Lantow on 01 Jun, 2020 02:54 PM

    Ben Lantow's Avatar

    Hey Jim,
    We're looking into this. Thanks for kicking over the log file, helps a ton. Give us a day or two for debugging and one of us will reach out.

    Thanks!
    Ben

  2. 2 Posted by r70 on 01 Jun, 2020 11:59 PM

    r70's Avatar

    Ben,
    Sounds good. If I can do anythine else to help please let me know.
    -Jim

  3. Support Staff 3 Posted by Ben Lantow on 03 Jun, 2020 04:57 PM

    Ben Lantow's Avatar

    We think this may be related to Java 14 specifically which was just released. If you download Java 13 instead (remove 14 completely), this should start working. We're going to figure out what the issue is and fix it but since Java 14 is so new, and so few users use APRS would you mind trying to use Java 13 instead?

    Here's a link to installers for 13: https://www.oracle.com/java/technologies/javase-jdk13-downloads.html

    Best,
    Ben

  4. 4 Posted by r70 on 03 Jun, 2020 05:00 PM

    r70's Avatar

    Hey Ben,

    Thanks for the quick response. I’m happy to try Java 13 in the next few days and will let you know.

    Thanks

    Jim

  5. 5 Posted by r70 on 04 Jun, 2020 03:03 AM

    r70's Avatar

    Hi Ben,

     

    I was able to install Java 13 and now offline sartopo comes up ok with the added lines for TNC in sar.properties . I’ll test the TNC connection sometime over the next few days.

     

    Note – I still had to update the path variable to include the java bin directory.

     

    Thanks for your help!

  6. Support Staff 6 Posted by Ben Lantow on 04 Jun, 2020 01:05 PM

    Ben Lantow's Avatar

    Thanks so much. We'll dig into this more.

    And yes Java in 13 and 14 no longer installs to the PATH for some reason. We're going to start packaging the entire release with Java for the future sometime in the next couple months.

    Best,
    Ben

  7. Ben Lantow closed this discussion on 04 Jun, 2020 01:05 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac