Instability problems with large maps

Whitney Potter's Avatar

Whitney Potter

12 May, 2020 09:47 PM

We are in the process of rolling out an Avenza training for Sonoma SAR and ran into some problems which seem related to very large maps. I made a bunch of 48"x48" maps which worked beautifully at first but when other people tried to download them they would sometimes just be blank. This happened whether you were bringing them into Avenza or hitting the map directly with a web browser. Since it seemed to be related to large maps I remade all the maps to 8.5x11 until we get this resolved. We rely so much on this service we don't want it to be unstable during a search.

Sorry I didn't get to meet Matt at the Marin MLPI training. Hopefully we'll get to do that in the fall.

  1. Support Staff 1 Posted by Julie on 12 May, 2020 09:59 PM

    Julie's Avatar

    Hi Whitney,

    Could you share a link to the maps with me so that I can take a look and see if iI can duplicate the problem?

    Thanks,
    Julie

  2. 2 Posted by Whitney Potter on 12 May, 2020 10:06 PM

    Whitney Potter's Avatar

    I replaced the problem maps with 8.5x11 versions for fear that we were
    causing strain on the server. I'll see if I can replicate the problem
    and send you the link.

  3. Support Staff 3 Posted by Julie on 13 May, 2020 03:41 PM

    Julie's Avatar

    Hi Whitney,

    A 48x48 map can be pretty huge, especially for a mobile device. They are really intended to be opened on a computer for printing. Our suggestion would be to start using the CalTopo app for sharing maps. We've been making a lot of great improvements to the app and our goal is to have everyone be able to use that instead of dealing with switching between programs. The CalTopo app will be faster and allow much easier track management in the Command Post.

    For my clarification, were you having people download the map to the phone, then import to Avenza? Or were you using a QR code to load straight from the web into Avenza?

    Many thanks,
    Julie

  4. Julie closed this discussion on 13 May, 2020 03:41 PM.

  5. Whitney Potter re-opened this discussion on 13 May, 2020 06:18 PM

  6. 4 Posted by Whitney Potter on 13 May, 2020 06:18 PM

    Whitney Potter's Avatar

    The problem showed up initially when people were trying to download into
    Avenza by scanning the QR from their screen (I didn't print 48x48"
    maps!) It worked fine for me. It was slower, but I was very pleased
    with the usability of having such a high resolution map on Avenza. You
    can zoom in and read street names and such over a very large area. But
    when I rolled it out to a few team members to test some of them had
    problems. Their downloaded map was a small file, Kb instead of Mb, and
    blank white and it pitched a warning popup that the map wasn't indexed.
    I duplicated this problem on my phone and when I tried hitting the same
    map on my laptop directly from SARTopo.com I got a blank white map as
    well. In this case the maps were pdfs stored in our SARTopo account. I
    could understand that an older phone would have problems with such a big
    file, but the problem happened directly on SARTopo. Interestingly a
    successful download took a while but the failure was much quicker.

    I thought that maybe I was pushing the system with such huge maps and
    things seemed to be breaking so I tried remaking the maps smaller but
    for a period of maybe an hour every pdf I tried to create was blank
    white. Eventually things started working again and I remade the maps at
    8.5x11 and had no problems. When we got in contact yesterday afternoon
    I reinstated the large maps in an attempt to replicate the problem for
    you, so far with no success.

    I wanted to make sure that I wasn't inadvertently creating a sort of
    distributed denial of service situation by having people download huge
    maps. We love SARTopo and rely on it heavily for search planning and
    management and the last thing we want to do is make it unstable while we
    or someone else is doing a search. So please let me know if it is
    advisable to use such large maps. They work great for what we are
    doing, but we don't want to turn over your server in the middle of an
    incident.

    I'll pass on the suggestion about the CalTopo app.

    thanks for your help,

    Whitney

  7. Support Staff 5 Posted by Julie on 13 May, 2020 06:25 PM

    Julie's Avatar

    Thanks for all the great info, Whitney! While the maps are big, they should still work eventually. I'll make sure our development team is aware of this and we'll try to replicate it. No one else has reported the problem, but then again I can't imagine people are building maps that big incredibly often unless there are a bunch of searches going on at the same time. Regardless, using the maps shouldn't cause the system to break. I do think the app will work better for your team overall.

    Best,
    Julie

  8. Julie closed this discussion on 13 May, 2020 06:25 PM.

  9. Julie re-opened this discussion on 13 May, 2020 06:53 PM

  10. Support Staff 6 Posted by Julie on 13 May, 2020 06:53 PM

    Julie's Avatar

    Whitney,

    One thing we thought of - PDFs are typically set to expire after 7 days, unless you manually set it longer when you create the map. This would perhaps explain why it worked at first when you tried, but disappeared later. Do you think this could be the case?

    Julie

  11. 7 Posted by Whitney Potter on 13 May, 2020 08:52 PM

    Whitney Potter's Avatar

    Knowing that these maps were going to be used in an on going training
    over the course of a couple of weeks I set them all to keep forever.
    The problems occurred within a few hours of when I made the maps.

  12. 8 Posted by Whitney Potter on 13 May, 2020 11:03 PM

    Whitney Potter's Avatar

    Try hitting https://sartopo.com/p/5C5F and see if you get a blank white
    screen. It is suppose to be a 48x48 map.

  13. 9 Posted by Whitney Potter on 13 May, 2020 11:34 PM

    Whitney Potter's Avatar

    Hi Julie,

    https://sartopo.com/p/3E44
    https://sartopo.com/p/3P70
    https://sartopo.com/p/5C5F
    are all coming up blank too

    I am attaching one of the blank maps which I downloaded in case that
    helps. I have experienced blank white maps when trying to make a pdf
    using google layers, but this isn't what is going on here. These are
    all derived from Open Street Map and they worked perfectly when I made them.

    Thanks for your help. I hope this helps make SARTopo even better.

    Whitney

  14. 10 Posted by Whitney Potter on 13 May, 2020 11:38 PM

    Whitney Potter's Avatar

    https://sartopo.com/p/5C5F seems to work now but
    https://sartopo.com/p/3E44 and https://sartopo.com/p/3P70 are still
    blank. Its a moving target. I hope this makes some sense on your end :-)

  15. Support Staff 11 Posted by Julie on 14 May, 2020 12:35 AM

    Julie's Avatar

    I am indeed running into the same problem. Thanks again for sharing. We'll dig into it.

  16. 12 Posted by Whitney Potter on 14 May, 2020 12:45 AM

    Whitney Potter's Avatar

    Thanks Julie. I'll leave the files there until you are done.

  17. Support Staff 13 Posted by matt on 14 May, 2020 04:11 PM

    matt's Avatar

    Those maps work for me. Reproducibility is going to be tricky because PDFs are cached for a while (so that repeated loads happen frequently), but that caching period isn't a fixed length of time but instead depends on how many other maps are getting generated.

    I do have a theory as to what's going on. All the maps you sent us are using the OpenStreetMap layer, which comes from OSM's server. Generating a 48x48 PDF requires loading a large number of tiles, and their server may be rate-limiting our requests. Do you have the issue when generating large PDFs with another layer like USGS or MapBuilder Topo?

    In the past I haven't had good luck getting Avenza to reliably load 48x48 DPFs, but that was years ago and their app may have improved since then.

  18. 14 Posted by Whitney Potter on 14 May, 2020 06:39 PM

    Whitney Potter's Avatar

    Thanks Matt. The problem seems intermittent, but I'm glad to know that
    we aren't crashing your server when it happens. I will test it with a
    different data set and see if we can reproduce it. You may be on to
    something with the OSM issue. I noticed one map which came up perfectly
    except that one tile was garbage. Which suggests the OSM server is under
    some strain. The huge maps seem to work beautifully on Avenza its just
    a matter of getting them on the phone in a way that works for our not so
    tech savvy searchers.

    Thanks for your help, and thanks for SARTopo, as I'm sure you know, it
    truly saves lives!

         Whitney Potter , Sonoma SAR 164

  19. Support Staff 15 Posted by matt on 18 May, 2020 07:18 PM

    matt's Avatar

    Just wondering if you were able to reproduce with a different dataset, or if it's OSM specific?

  20. 16 Posted by Whitney Potter on 18 May, 2020 10:41 PM

    Whitney Potter's Avatar

    I actually took a different approach to solving the problem. I used
    your handy custom QR feature to make maps with QR's that point to one of
    my websites and then hosted the collection there as static files. That
    way they serve faster and they aren't loading your server and cluttering
    up our team account needlessly. I just did a collection of all the
    parks in Sonoma County at fairly large size (24-30"), mostly map builder
    layers, and it performed flawlessly. The things I do to convince our
    graying team members to embrace technology. . .

    I think you are on the right track with OSM. I experienced frequent
    outages with their servers when working on a collection of 3d printed
    trail maps of all the Tahoe ski areas.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac