Delete button doesn't delete objects until page refresh

Adam's Avatar

Adam

21 Nov, 2019 03:44 PM

On my maps, when I hit the delete button for a marker... it says "are you sure?" and I say "yes". but then nothing happens. the marker remains.

only once i refresh the map page and reload everything is the marker gone. this works reliably, so it's not the worst bug in the world, but it's a bit annoying.

for another clue: if i try to delete a marker per the above standard process and it doesn't disappear... then i try to delete it again (before refreshing the map), i get the following error: "Server Communication Error! Data may not be getting saved properly, reloading this page may solve the problem. This message will not be shown again until you reload the page, but the problem may persist" - so clearly the map recognizes that the object was deleted, but for some reason the object persists visually and in the list on the left until page refresh.

i'll survive : ) but it would be sweet to get to root cause of this bug! anyone else experiencing it? am i all alone in the world?

  1. Support Staff 1 Posted by Ben Lantow on 21 Nov, 2019 06:56 PM

    Ben Lantow's Avatar

    Hi Adam,
    I'm unable to duplicate this error, I just tried on a couple maps. Are you using the red x in the right hand bar to delete the marker or are you using the popup dialog box? Are you in an area of intermittent service? This sounds like a communication problem between your device and the server.

    Best,
    Ben

  2. 2 Posted by Adam Libert on 21 Nov, 2019 09:25 PM

    Adam Libert's Avatar

    Thanks for getting back to me!

    Yeah hmmm... I've been working a lot on two maps that have a lot of data in
    them. I thought the bug persisted in both of them, but it's only happening
    in one of them now - maybe I had a bad memory here. Notably, i tried on
    third map of mine (with less data) and it works just fine. So just one map
    is the issue.

    The bug persists whether i use the x in table of contents list or in the
    popup dialog box. Doesn't matter. No internet or computer issue - bug
    persists on multiple computers at work and at home.

    Oooh I just went to make a bunch of test points to try deleting them... but
    they deleted fine. The issue seems to be just with the points i already
    have in the map. I believe that most of these I imported (rather than made
    in caltopo) via GeoJSON or similar. Perhaps there's some pesky bug in the
    imported waypoints metadata.

    I just tried exporting some "stubborn" points to GeoJSON, then deleting
    them (requiring refresh), then re-importing them... then deleting them
    again... they delete just fine the second time around. Maybe I should just
    export my library and re-import it to start fresh. what a quirky bug.

     - Adam.

  3. Support Staff 3 Posted by Ben Lantow on 21 Nov, 2019 09:43 PM

    Ben Lantow's Avatar

    Looks like good diagnostic. That said, if there is an underlying bug I'd like to fix it. Can you send a link to the map and I'll have a developer take a look. If you want to export and reimport and work off that to get around it for now totally understand that but we'll see what happened to the first map.

  4. 4 Posted by Adam Libert on 22 Nov, 2019 06:49 AM

    Adam Libert's Avatar

    i love your dedication to this. as if i already didn't think caltopo was
    one of the best sites on the internet, to know it's got motivated support
    and developers behind it... i'm inspired.

    map is this one: https://caltopo.com/m/P3QS - it's a compilation of hot
    springs i've been putting together. currently it's a huge mess, but wanted
    to focus on content first. i'll clean it up. let me know if you need an
    "edit" password so you can try the delete action, though maybe your devs
    don't need this with their super powers. i will ask that you don't share
    this map widely without asking me. i'm putting in a lot of effort and want
    to be respectful of tucked away little hot springs and not contribute to
    blowing up hidden gems. keeping it as a resource for me and some friends.

    if you want to try out the delete feature, here are some different markers
    that you can feel free to delete - just let me know which ones you deleted,
    or put them back on after you delete them. no worries about the
    description/icon, so long as the marker is in the same place and name is
    right.

       - One that I deleted (requiring refresh) and then re-added manually: AZ
       Hot Springs -> Hannah Hot Springs
       - One that I exported to JSON, deleted (requiring refresh), re-imported,
       then was able to easily delete with nominal process: AZ Hot Springs -> El
       Dorado Hot Springs
       - Two springs that you can try deleting that I haven't messed with yet
       so they should present the bug i've been talking about: CA Hot Springs -> a
       sea mountain nude resort (ha) and Hope Springs Resort (no worries about
       returning these data points - they aren't what i'm looking for on my map
       and i'll be removing them myself later anyway)

    Hope this is helpful! Feel free to email or call (617-480-1546) any time.
    I'm happy to help support such an awesome app + team

     - Adam.

  5. Support Staff 5 Posted by Ben Lantow on 22 Nov, 2019 06:27 PM

    Ben Lantow's Avatar

    In looking at this I actually know what the likely problem is. We had a bug with special characters that we fixed last week. There are a lot of characters on this map that fall into that special characters category. I would export the entire map as a geoJSON, reimport it and work off the new one with our improved/fixed special character handling. I think that should fix the problem going forward.

    Best,
    Ben

  6. Ben Lantow closed this discussion on 22 Nov, 2019 06:27 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac