Problem clicking on trails when drawing a line

Andrew's Avatar

Andrew

08 Sep, 2019 05:26 PM

I'm having an issue clicking on trails when drawing a line. The line doesn't seem to want to snap to the trail, it just wants to be a straight point to point line. You have to float the mouse over the trail and move it back and forth and click at the exact right time for it to snap. This seems to have started maybe a month or two ago. It happens the same on safari and chrome on mac or PC.

If my description was no good, here's a link to a screen recording. Also attached.
https://streamja.com/LLjK

  1. 1 Posted by Chad R. on 08 Sep, 2019 09:34 PM

    Chad R.'s Avatar

    I have been having the same issue, both Chrome and Firefox on Windows, latest versions of each. Timeline sounds right as well, for maybe the past month or two.

  2. Support Staff 2 Posted by Ben Lantow on 09 Sep, 2019 04:39 PM

    Ben Lantow's Avatar

    This is a little more finicky than intended for sure. I have a suspicion of what it could be. Are you logged in? Or are you logged in but to a free account?

  3. 3 Posted by Andrew on 09 Sep, 2019 05:07 PM

    Andrew's Avatar

    I'm logged in with a paid basic account.

  4. Support Staff 4 Posted by Ben Lantow on 09 Sep, 2019 06:02 PM

    Ben Lantow's Avatar

    Well drat I hoped that was related to the issue. I'll see what I can figure out. Thanks

  5. Support Staff 5 Posted by Ben Lantow on 09 Sep, 2019 11:06 PM

    Ben Lantow's Avatar

    Matt. I was wondering if this was a leaflet issue, but it doesn't seem like it. That said, I cannot replicate how finnicky it is in the video on my machine. Thoughts?

  6. Support Staff 6 Posted by matt on 10 Sep, 2019 07:15 PM

    matt's Avatar

    I'm sorry but I don't have any insight right now. I looked at our change history from early June through late July, and nothing is jumping out at me as likely to be the cause of this issue.

    I'm able to reproduce on occasion, by sweeping my cursor up towards where the line is anchored, as I move it left-to-right. I believe this is causing the cursor to mouse over the straight line that's being shown, and being over the straight line blocks it from triggering on the trail, if that makes sense. Can you try sweeping the mouse down, away from the last point, as you move it left-right? Does that solve the problem all the time, or only on occasion?

    I realize your video also shows you successfully snapping, then clicking, and then getting a straight line. Might be related but will need to ponder that one a bit more.

  7. 7 Posted by Andrew Hermiz on 11 Sep, 2019 01:10 AM

    Andrew Hermiz's Avatar

    Thanks for looking, I appreciate it. If anything changes I'll post again.
    It doesn't happen all the time and when it does it's not too terrible.

    I think the thing in the video with snapping and then getting a straight
    line is because I had to sweep the cursor back and forth over the line to
    get it to snap, it then snaps momentarily but by the time I react it's too
    late.

    Thanks again

  8. 8 Posted by sue on 15 Sep, 2019 04:59 PM

    sue's Avatar

    I haven't been able to figure out how to move or remove a large portion of a line/trail. mine consist of may vertices and it would take hours to delete them all one by one.
    suggestions?

  9. 9 Posted by Andrew on 15 Sep, 2019 05:06 PM

    Andrew's Avatar

    Sue,
    Try clicking the line where you want to break it and using the split button. It'll break into two lines. You can then delete the line you don't want.

  10. Support Staff 10 Posted by Ben Lantow on 15 Sep, 2019 06:33 PM

    Ben Lantow's Avatar

    Andrew's suggestion is exactly what we would recommend in this specific instance.

  11. 11 Posted by sue elson on 15 Sep, 2019 06:43 PM

    sue elson's Avatar

    thanks

  12. Ben Lantow closed this discussion on 15 Sep, 2019 06:51 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac