Composite Custom DEM Shaders no longer working

Travis Prescott's Avatar

Travis Prescott

05 Sep, 2019 02:08 AM

For a while I have used a custom DEM shader with the following rule:

s30-45t0-50 FF0000

It highlights areas from 30-45 degrees with less than 50% canopy in red. However, I noticed today that now, no matter what I put for the canopy values, CalTopo ignores and highlights the same area (30-45 degrees) regardless of whether I specify <10% or <100% canopy!

  1. Support Staff 1 Posted by Ben Lantow on 05 Sep, 2019 03:56 AM

    Ben Lantow's Avatar

    Hi Travis,
    I'm seeing a similar behaviour to what you describe here. I do not believe that is intended. I've sent this on to our developer Matt to take a look at. Typically he responds in 24-48hrs.

    Best,
    Ben

  2. Support Staff 2 Posted by matt on 05 Sep, 2019 10:23 PM

    matt's Avatar

    Thanks for letting us know. It should still work at zoom levels 12 and below but there was a bug with the code that blows the canopy data up for higher zoom levels (refactored as part of app development). Have it fixed in the code base, will try to get that deployed tonight.

  3. 3 Posted by Travis Prescott on 07 Sep, 2019 12:48 AM

    Travis Prescott's Avatar

    It looks like the issue is still occurring. I have a rule here that highlights canopy >50% green and my rule that is supposed to highlight angles 30-45 degrees and < 50% canopy in red. But you can still see the overlap.

    There was an issue I was seeing where aspect shading didn't work unless I was zoomed way out--that seems to have been fixed.

  4. 4 Posted by Travis Prescott on 07 Sep, 2019 12:48 AM

    Travis Prescott's Avatar

    Not sure why it didn't attach the picture.

  5. Support Staff 5 Posted by matt on 07 Sep, 2019 11:43 PM

    matt's Avatar

    Can you provide a link to the map? I can't tell what's going on from the screenshot since it looks like there's green vegetation shading as part of the topo map as well, and I'm not sure what's that vs your rules.

    I tested this and it's fixed in the area I was looking at. Any chance you have cached map tiles from when it was broken, and need to clear your browser's cache?

  6. 6 Posted by Travis Prescott on 08 Sep, 2019 05:50 PM

    Travis Prescott's Avatar

    I tested it again this morning and it's working fine. Thanks for the quick fix!

  7. 7 Posted by Travis Prescott on 08 Sep, 2019 08:27 PM

    Travis Prescott's Avatar

    Looks like I spoke too soon. Tried this again today to re-record the training session I had made and it is still broken. Here's a link to the map: https://caltopo.com/l/C1SF

    Shader 1: s30-45t0-50 FF0000
    Shader 2: t50-100 00CD00-00CD00

    The map layer is 2013 Forest Service, so there's no coloration from the map. These two shaders should produce non-overlapping areas, but the composite shader (1) is only considering the slope angle, not the canopy.

  8. Support Staff 8 Posted by matt on 09 Sep, 2019 04:15 AM

    matt's Avatar

    Did you clear your browser cache? It is showing up as non-overlapping for me (see attached image).

  9. 9 Posted by Travis Prescott on 10 Sep, 2019 05:16 AM

    Travis Prescott's Avatar

    Okay, yes, it looks like clearing the browser cache fixed the issue. It's now working as expected. Thank you!

  10. Ben Lantow closed this discussion on 10 Sep, 2019 05:36 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac