Adding a Key

Ryland 's Avatar

Ryland

24 Aug, 2019 07:54 PM

For some reason I can no longer add a key to my PDFs. I am either missing something very simple, or my browser is malfunctioning, or...
I have tried jpg, gif, png, all 4 quadrants, new PDF, load from an old pdf, but it will not show up. I have done it in the past successfully and I think I used the same steps...

Ry

  1. Support Staff 1 Posted by rmarcucci on 25 Aug, 2019 09:46 PM

    rmarcucci's Avatar

    Ryland,

    I'm guessing your referring to the ability to add custom images or a qr code to the corners of the PDF printouts. If this is the case, and you can't do it, it's likely due to your subscription lapsing as this is a pro level feature. I tried to look up your account in our back end but couldn't find anything associated with this email address or your name.

    Please let me know if you need any additional help and thank you for using CalTopo,
    Rom

  2. rmarcucci closed this discussion on 25 Aug, 2019 09:46 PM.

  3. Kendrick, Ryland re-opened this discussion on 25 Aug, 2019 10:17 PM

  4. 2 Posted by Kendrick, Rylan... on 25 Aug, 2019 10:17 PM

    Kendrick, Ryland's Avatar

    The email I sign in with is [email blocked], and I did link the account to our usar team at [email blocked].

    As far as I know my account is in good standing. I am not sure when the last billing was but I recall a renewal a while back, and I did create a key about a month or two ago and I have not gotten a bill or anything like that since then.

    Ry (mobile)
    ________________________________

  5. 3 Posted by Kendrick, Rylan... on 26 Aug, 2019 10:53 AM

    Kendrick, Ryland's Avatar

    I have the Offline Account level, so I think adding a key should work.

    [cid:[email blocked]]

  6. Support Staff 4 Posted by rmarcucci on 26 Aug, 2019 03:30 PM

    rmarcucci's Avatar

    So strange, the feature is working fine for me and your permissions look good on the back end as well. I'm going to forward this along as it's beyond me.

  7. 5 Posted by Kendrick, Rylan... on 26 Aug, 2019 03:31 PM

    Kendrick, Ryland's Avatar

    I’ll try again and document my steps.

    Ry (mobile)
    ________________________________

  8. 6 Posted by Kendrick, Rylan... on 26 Aug, 2019 05:25 PM

    Kendrick, Ryland's Avatar

    Got it to work, but not consistently. Sometimes is printed a key, sometimes it did not.

    Another question/request: is it possible to know (or specify) the pdf URL suffix before generating the pdf so it can be printed on the key?

    Ry

  9. Support Staff 7 Posted by Ben Lantow on 26 Aug, 2019 06:27 PM

    Ben Lantow's Avatar

    Well thats weird. I also tried in my account - no issues here with putting a key on a map. Can you send me the file you're using and the address of the map (should be http://caltopo.com/m/XXXX). I can do a little debugging to see if there is something else going on here.

    Best,
    Ben

  10. 8 Posted by Kendrick, Rylan... on 26 Aug, 2019 06:34 PM

    Kendrick, Ryland's Avatar

    (https://sartopo.com/m/NFGF

    All of the recent PDFs for that map in my account were supposed to have Keys. Some do, some don’t. I imagine I did something but I can’t figure out what.

    One other question about the iOS app: if multiple people are viewing the map, and all are saving tracks to the map, can they see each other?

    Ry

  11. Support Staff 9 Posted by matt on 26 Aug, 2019 10:54 PM

    matt's Avatar

    Yes, tracks saved to the map are visible to all users, just like other map objects. We also have a location sharing feature planned for team accounts, for situations where you just care about the current location and not the track tails.

    You can't know the PDF URL in advance, in order to do that you'd have to self-host the PDF and override the QR code plus key with your new URL. The one exception is that the "save as" dropdown allows you to overwrite an existing PDF on your account, so you could create a dummy PDF and then overwrite it with your new one. The dropdown is only populated on page load, so you'd have to re-open the print page another time.

    Querying the database, here's what I see for your PDFs. Any PDF with NULL doesn't have corners set; it looks like the issue is in the corners getting uploaded in the first place, rather than the PDF generator not rendering them.

    The next time you have a failure, can you send over the exact image you're using? Would be helpful to run a few tests and see if it's random, or if the same image will always fail.

    +------+-----------------+ | name | length(corners) | +------+-----------------+ | 031K | 33362 | | 0L73 | NULL | | 130U | NULL | | 2R6K | NULL | | 2T0A | 33362 | | 3C3R | 33362 | | 427N | 29119 | | 4E2R | NULL | | 6854 | NULL | | 6Q5B | 54724 | +------+-----------------+

  12. 10 Posted by Kendrick, Rylan... on 28 Aug, 2019 12:29 AM

    Kendrick, Ryland's Avatar

    Just opened the latest beta. Labels from the map do not show (has that always been the case?), and on the website I have the UTM grid on, and it used to show up on the phone, but now does not.

    Ry

    From: Ryland Kendrick <[email blocked]>
    Sent: Tuesday, August 27, 2019 8:27 PM
    To: Kendrick, Ryland <[email blocked]>
    Subject: Screenshot 2019-08-27 at 20.25.24

    [cid:[email blocked]]

    Ry (mobile)

  13. Support Staff 11 Posted by Ben Lantow on 28 Aug, 2019 01:05 AM

    Ben Lantow's Avatar

    What are the labels that are showing up red X's? We did update our SVG graphics to clean up all the markers and maybe there is a problem with some of them in the app. Can you send me the map link as well?

    As for the UTM lines not showing up I've logged that issue, right now if I recall we haven't added the functionality to the map yet, it may have been carrying over from the web somehow weird. I'll dig into it more though tonight or tomorrow.

  14. Ben Lantow closed this discussion on 28 Aug, 2019 01:05 AM.

  15. Kendrick, Ryland re-opened this discussion on 28 Aug, 2019 02:05 AM

  16. 12 Posted by Kendrick, Rylan... on 28 Aug, 2019 02:05 AM

    Kendrick, Ryland's Avatar
  17. Support Staff 13 Posted by Ben Lantow on 28 Aug, 2019 02:12 AM

    Ben Lantow's Avatar

    Ohhhhh

    I see what the problem is. I’ll dig into it more with developer team tomorrow. We are on an approximately 2 week beta cycle. I think this can make it into the next release along with more tracking bugs, some UI optimization, etc.

    Best,
    Ben

  18. 14 Posted by Kendrick, Rylan... on 28 Aug, 2019 02:15 AM

    Kendrick, Ryland's Avatar

    Thanks!

    Ry

  19. Support Staff 15 Posted by Ben Lantow on 28 Aug, 2019 04:14 AM

    Ben Lantow's Avatar

    Can you confirm your settings for this? 3 bar menu in the left corner, map settings, and you'll see the UTM grid and show/hide labels there.

    If they are set correctly and you still aren't seeing labels or UTM grids let me know.

    I had looked the wrong spot for UTM grid option that was my mistake.

  20. 16 Posted by Kendrick, Rylan... on 28 Aug, 2019 12:35 PM

    Kendrick, Ryland's Avatar

    My error. Both on now.

    So the mobile app will not carry over the setting from the website?

    Ry (mobile)
    ________________________________

  21. Support Staff 17 Posted by Ben Lantow on 29 Aug, 2019 05:41 PM

    Ben Lantow's Avatar

    So settings inherent to the map itself will carry over. However if you look online, UTM grid is not map dependent, it will stay on once you turn it in regardless of if the map was made with that grid on. Same with labels. We do not currently sync application wide settings between app and web for a variety of reasons, but primarily because people are looking at maps for different reasons on their phone than web and may want different settings to persist.

    And no worries - I didn't even think to check settings at first, my bad as well.

  22. Ben Lantow closed this discussion on 29 Aug, 2019 05:41 PM.

  23. Kendrick, Ryland re-opened this discussion on 29 Aug, 2019 05:49 PM

  24. 18 Posted by Kendrick, Rylan... on 29 Aug, 2019 05:49 PM

    Kendrick, Ryland's Avatar

    That makes sense. It occurs to me that I should probably make a grid instead of depending on the UTM grid. That’s what all those round numbers and letters are for, just to act as grid reference points. Mainly for our printed map but also for looking at it online.

    I wonder how difficult it would be to come up with a grid tool, that is, an object that looks like a grid with built-in axes…

    I guess right now tracing the UTM grid using lines would be the easiest.

    Ry (mobile)
    ________________________________

  25. Ben Lantow closed this discussion on 29 Aug, 2019 06:18 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac