Downloaded KMZ "is not a valid KMZ file" for Garmin and printed map is blank

Wes's Avatar

Wes

21 Aug, 2019 02:04 PM

I'm having trouble importing downloaded KMZ files into Garmin BaseCamp and am not sure how to troubleshoot; this process was working for me a few months ago!

My base layer is "Scanned 7.5'"; I select "Print" > "Download KMZ or MBTiles File" > "Download KMZ", then drag the file into Garmin BaseCamp, which throws an alert message that the file "is not a valid KMZ file and could not be opened."

I have attached an example KMZ file that I downloaded this way from CalTopo. I'm not sure how else to read this file to validate it...I tried changing the extension to ".zip" but this unzips to ".zip.cpgz", which itself unzips back to ".zip", so it seems the file is not complete. Are you able to confirm if this file is what you would expect to be downloaded?

I'm using Firefox 68.0.1, though I have also tried Chrome 76.0.3809.100 and Safari 12.1.1 (14607.2.6.1.1). I have also tried other base layers.

Perhaps this should be a separate issue, but I also tried printing the map and this too doesn't work! I select "Print" > "Print to PDF or JPG", but "Generate PDF" always shows a white page regardless of the configuration I select (scale or format). I did see this issue (http://help.caltopo.com/discussions/bugs/4143-custom-tiles-cannot-print) but don't think it's related as I'm not using custom tiles.

Thank you!

  1. Support Staff 1 Posted by Ben Lantow on 21 Aug, 2019 02:19 PM

    Ben Lantow's Avatar

    Hi Wes,
    This file is not valid. You're not doing something wrong here. I just tried to both import it to Google Earth and then dig into it a little and extract the data and it's just not working, its only 37bytes (way smaller than I'd expect). What map was this from? Can you give me the web address on Caltopo? I think the root problem especially with the PDF problem is related to the actual map.

    Best,
    Ben

  2. 2 Posted by Wes on 21 Aug, 2019 02:29 PM

    Wes's Avatar

    Thanks for your quick response! The map url is https://caltopo.com/m/7PAF ; I'm not sure if it matters where it's centered (there's tracks and waypoints), but what I'm trying to export is centered at 41.0305, -122.9138

    Is this the information you need?

  3. Support Staff 3 Posted by Ben Lantow on 21 Aug, 2019 02:32 PM

    Ben Lantow's Avatar

    Thats what I need. Let me do a little investigating and I'll get ya some answers.

  4. Support Staff 4 Posted by matt on 21 Aug, 2019 09:00 PM

    matt's Avatar

    Wes -

    Sorry, there is a bug with the CalTopo site and some of the data you have on that page. Marker style (shape, color, rotation) is packed into a single string, and somehow, some of your markers have the same color listed multiple times in that string.

    If you use the bulk ops menu to select all of your red-dot markers and re-specify them as red dots, I think that will reset them, but I'm not 100% sure.

    I'd like to figure out how this happened in the first place. I might be missing one, but the affected markers seem to be "Mt. Fitz Roy", "Parque Nacional", "Volcán Lonquimay", "Parque Nacional Tierra del Fuego", "Banff National Park", "Valle Francés", "Parque Nacional Conguillío". Any details you can give me on how those markers specifically were created, e.g. did you import them from somewhere, change the style repeatedly, etc?

    • Matt
  5. 5 Posted by Wes on 21 Aug, 2019 11:12 PM

    Wes's Avatar

    That fixed both issues, thanks so much! In the sidebar, I could see where the marker icon appeared to be a broken-image-url icon; and for these markers, color was "N/A" and uneditable until I first selected the market type, after which I could then select the color. (attached image shows what the 'edit marker' window looked like when I couldn't change the color)

    I'm not sure how this happened; I created these markers by hand. I likely changed the style a few times. But something that could have broken this map is that a couple months ago I tried to combine two maps. I didn't see a feature for this, so I thought I would achieve it by copying the set of waypoints and lines from one map to another. The other map was https://caltopo.com/m/A5EQ. Unfortunately, I can't remember which was the source and which was the destination or exactly how I attempted this; I think I exported the objects as KML and then imported them into another map. But this process didn't work; A5EQ lost a bunch of objects. Maybe something during the KML import invalidated the color attributes. I'm not sure.

    At any rate, thanks for determining the cause of this issue!

  6. Support Staff 6 Posted by Ben Lantow on 22 Aug, 2019 06:44 PM

    Ben Lantow's Avatar

    Wes,
    So glad we got it fixed. Weird issue. But yay!

    Thanks for using CalTopo

  7. Ben Lantow closed this discussion on 22 Aug, 2019 06:44 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac