Problems starting up local server

Steve Weiss's Avatar

Steve Weiss

09 Aug, 2019 03:47 PM

I have downloaded the necessary files for Windows, in order to use SARTopo offline.

However, I seem to be having some inconsistent behavior relative to the instructions for installing SARTopo offline on Windows. Worse still, I cannot connect to the localhost address. I am running Windows 10 and trying to open SARTopo offline via Chrome (as recommended).

Inconsistences (and attempted mitigations)
(1) The version of Java JDK is now Java SE 12.0.2; that is what I downloaded.
(2) Running the .bat file popped up the command window ever so briefly, then it disappeared, with no intervention by me (I tried running both .bat files, the regular one and the one for Java v 9 and 10; I get the same disappearing command window with both batch files)

Taken altogether, I get "ERR_CONNECTION_REFUSED" when trying to link to the localhost server as directed.

I have updated firewall and proxy settings as follows:
* Firewall: Through Windows Defender settings, OpenJDK is an app that is allowed access through the firewall
* Proxy: Following recommendations from Chrome, I have set the proxy settings as: "Use a proxy server for your LAN" (though the default settings haven't worked either).

What am I missing?

Thanks!
Steve Weiss
Shenandoah Mountain Rescue Group

  1. Support Staff 1 Posted by Ben Lantow on 09 Aug, 2019 04:20 PM

    Ben Lantow's Avatar

    Hi Steve,
    I'm thinking this is likely related to Java 12, we had some issues recently when I was trying to run on my computer with Java 12 that we are still digging into. I think the first thing to try would be uninstalling Java 12 completely and then download and install Java 9 (https://www.oracle.com/technetwork/java/javase/downloads/java-archi...) and attempt to run the application.

    We are working on getting it running correctly in Java 12 but as of today I think that may be the source of the issue. I'm going to also kick this to one of the developers and see if he has any other thoughts.

    Sorry for the trouble!

    Let us know if reverting to an older Java fixes the problem.

  2. 2 Posted by Steve Weiss on 09 Aug, 2019 09:18 PM

    Steve Weiss's Avatar

    Reverting to Java 9.0.4 seems to have done the trick.
    Thanks!

  3. Support Staff 3 Posted by Ben Lantow on 10 Aug, 2019 04:29 AM

    Ben Lantow's Avatar

    Great I'm glad to hear that. We have an update to the offline app on the way that will remedy this issue but for now it turns out that using the older version of Java is the fastest and easiest way. Keep an eye out for the offline app update!

    Best,
    Ben

  4. Ben Lantow closed this discussion on 10 Aug, 2019 04:29 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac