Imported GPX Route Won’t Print

Barry Vaughan's Avatar

Barry Vaughan

09 Jul, 2019 02:40 PM

I’m not sure whether this is a bug or just a newbie user item. When i create a route gpx file in the ipad footpath app and import it into caltopo on ipad safari, then go to print, the route disappears on the print sizing/other options pane. I think i stumbled onto a workaround last year but can’t recreate it. How do you print a gpx in caltopo?

  1. 1 Posted by Barry Vaughan on 09 Jul, 2019 02:54 PM

    Barry Vaughan's Avatar

    Found the answer. It’s a newbie user item. You need to save the map before you select print. The the track is shown on the print options page and prints onto the pdf as well.

  2. rmarcucci closed this discussion on 10 Jul, 2019 03:17 AM.

  3. matt re-opened this discussion on 10 Jul, 2019 03:31 AM

  4. Support Staff 2 Posted by matt on 10 Jul, 2019 03:31 AM

    matt's Avatar

    That sounds like a bug related to that specific file, a GPX file shouldn't be treated differently than any other data when printing. Can you attach the GPX file or send a link to a CalTopo map with the file loaded on it?

  5. Support Staff 3 Posted by matt on 10 Jul, 2019 03:32 AM

    matt's Avatar

    Sorry Barry, I don't know why I didn't see your second message, but saving the map still shouldn't be necessary. However since it prints fine from a saved map, if can send the actual GPX file, that would help me debug the issue.

  6. 4 Posted by Barry Vaughan on 10 Jul, 2019 03:54 AM

    Barry Vaughan's Avatar

    here you go. it happened last summer too i think, with other routes.
     since saving the route file before printing solves the problem,
    maybe the issue is academic at this point.

    thank you though for your response and your interest.

    Barry Vaughan
    310-864-0777

  7. Support Staff 5 Posted by rmarcucci on 17 Jul, 2019 08:31 PM

    rmarcucci's Avatar

    Barry,

    Sorry for the delay getting back to you. Somehow this ended up in our spam folder and I just caught it. Matt should get back to you on this tomorrow.

    Thank you,
    Rom

  8. 6 Posted by Barry Vaughan on 17 Jul, 2019 09:35 PM

    Barry Vaughan's Avatar

    Sounds good

    Barry Vaughan
    310-864-0777

  9. Support Staff 7 Posted by matt on 18 Jul, 2019 05:39 PM

    matt's Avatar

    Odd, I can import that file and print (https://caltopo.com/p/7N1A) without issue, and without first saving to a map. This is on desktop Safari. I haven't tried on an iPad (can can't right now) - wondering if you have the same issue importing and then printing the file on a computer, or if maybe it's iPad specific.

  10. 8 Posted by Barry Vaughan on 18 Jul, 2019 10:21 PM

    Barry Vaughan's Avatar

    Matt,

    It may be ipad specific. I appreciate your looking into it, but since it’s no prob to save the map before printing it that to me is a very satisfactory work around. Thanks for looking into it.

    Barry Vaughan
    310-864-0777

  11. Ben Lantow closed this discussion on 16 Aug, 2019 11:50 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac