Snap to lines feature isn't working for polygons

Maddy Grubb's Avatar

Maddy Grubb

29 May, 2019 07:00 PM

I'm trying to create a set of polygons off of lines I have already drawn. The project file size isn't very big (3 mb I think) yet each time I try to switch over to the "snap to lines" setting the program stalls and there is a message that says "Auto-Draw is being turned off cause it has taken too long to generate a route map".

Iv'e tried It with multiple browsers and on 2 devices with the same results. Any help would be much appreciated! Thank you!!

  1. Support Staff 1 Posted by matt on 29 May, 2019 10:26 PM

    matt's Avatar

    What's the map ID? I can take a look.

    Normally this happens if you have polygons or lines with overlapping edges. The routing system is mostly designed around handling imperfect OpenStreetMap road / trail data, and tries to split the lines every place they touch - if you have two lines that touch each other for an extended distance, this can grind it to a halt.

  2. 2 Posted by Maddy Grubb on 29 May, 2019 10:48 PM

    Maddy Grubb's Avatar

    Oh shoot that’s definitely it. Thanks for the help Matt!
    -Madi

  3. matt closed this discussion on 30 May, 2019 03:57 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac