Printing PDFs from large map file stalls out on /linkpdf url

Gabriel's Avatar

Gabriel

18 Feb, 2019 08:52 PM

I'm trying to print to a PDF sections of a large caltopo map: https://caltopo.com/m/0MMH

Unless I turn off most of my lines and polygons I can't get the PDF to load. Attached are some screen shots.

I'm using terrain shading and USFS/USGS tiles, and have varying transparencies with lines and polygons.

Thanks for any workarounds, I've tried (on a mac) both Safari and Chrome.

  1. Support Staff 1 Posted by matt on 21 Feb, 2019 05:21 PM

    matt's Avatar

    I don't have much to suggest; I'm having trouble loading that page due to size so I can't verify exactly where the issue is. However turning off individual objects on the map viewer (via config -> set visibility -> by item if necessary) will cause those objects not to get sent to the print preview page or the PDF generator, so if you are only printing coverage for a small area, turning off the objects that won't appear on the PDF anyway will help.

  2. 2 Posted by Gabriel Amadeus... on 21 Feb, 2019 05:42 PM

    Gabriel Amadeus Tiller's Avatar

    Thanks for the reply. Yep, it's a really large file and turning items off
    was the best workaround I found.

  3. matt closed this discussion on 25 Feb, 2019 04:53 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac