slow load times

ben's Avatar

ben

12 Jan, 2019 11:23 PM

i'm not sure if this is technically a "bug", but for the last few months, i've noticed caltopo loading new data *much* slower than it used to. i.e., i'll drag a map and it will take several seconds for new data to appear in the blank squares created by the drag. it also sometimes takes a minute for the box in the upper right hand corner to show the actual elevation at the cursor. it may run faster with less layers/information, but not dramatically so.

is this a known thing? are others experiencing it?

  1. Support Staff 1 Posted by matt on 13 Jan, 2019 11:21 PM

    matt's Avatar

    Not something I'm aware of.

    Does this happen regardless of the map layer you have selected (the three to test for comparison purposes would be Google Maps, MapBuilder Topo and USGS 7.5')?

  2. 2 Posted by Ben Sterling on 14 Jan, 2019 02:43 AM

    Ben Sterling's Avatar

    it's similarly slow on the usgs and mapbuilder. however, google maps (and
    satellite, which i also checked) is lightning quick.
    i use chrome typically, but checked it in safari as well (without even
    logging in to the site) and it's the same.

  3. Support Staff 3 Posted by matt on 03 Feb, 2019 04:05 AM

    matt's Avatar

    Wondering if this has improved for you? I don't have any good benchmarks for an objective comparison, but there have been some recent caching changes that I'm hoping will speed things up.

  4. 4 Posted by Ben Sterling on 04 Feb, 2019 07:09 PM

    Ben Sterling's Avatar

    it *might* be a little faster now? it's hard for me to put a finger on the
    issue. i don't think it's my internet speed. i do have one very busy map,
    with tons of lines and many, many waypoints on it. i thought that perhaps
    it was simply too big. but sometimes my smaller maps (like for a 2 night
    trip) also load tiles very sluggishly. it's not the end of the world,
    though it's a bit like walking through mud. let me know if there's any
    other information from my side i can pass along! thanks.

  5. 5 Posted by Nirmal Vuppulur... on 15 Feb, 2019 06:06 PM

    Nirmal Vuppuluri's Avatar

    I can confirm this as well, although I've been seeing this problem over the last month or so. I have tried all kinds of browsers on both windows and MAC, but I see the same very slow load times. I also tried clearing out all cache, but no dice.

    1. Sometimes, loading caltopo.com itself takes a long time and I have to reload, sometimes multiple times.
    2. If I want to add a new route, the OSM/USFS snap lines show up very slowly, sometimes only partial lines show up and sometimes the lines don't show up at all.
    3. I tried starting with a blank map and it still happens. I tried the USGS, Mapbuilder, Google, USFS 2016.

    If there's any more info you want me to give you, I'm happy to help. Right now, it's kind of become unusable for me. Thanks!

  6. 6 Posted by Eric on 15 Feb, 2019 06:31 PM

    Eric's Avatar

    Can also confirm, Caltopo site overall feels "sluggish". The Google-based Baselayers are very quick, but custom layers, etc, load very slowly or incompletely. I'm on a healthy 300Mbit business connection, so it's not my connectivity/ISP.

  7. Support Staff 7 Posted by matt on 15 Feb, 2019 06:33 PM

    matt's Avatar

    There have been some performance issues over the last 24-36 hours that we're working on, which are separate from any long-term performance issues.

  8. 8 Posted by Ben Sterling on 15 Feb, 2019 07:21 PM

    Ben Sterling's Avatar

    yeah, it has been very, very slow the last day or so, which is a different
    order of magnitude than the original slowness i am experiencing. :)

  9. 9 Posted by Eric on 15 Feb, 2019 10:43 PM

    Eric's Avatar

    Well, if you guys did something in the meantime it really helped, the site is much more responsive and my custom layers (terrain modeling) are drawing quickly!

  10. 10 Posted by Ginger on 17 Feb, 2019 04:59 PM

    Ginger's Avatar

    FYI - have used CalTopo easily for years on slow IE11 Windows 7 computer.
    Now it won't load at all and just get the few lines of text...pasted below.
    All working okay if I switch over to Chrome or Firefox...so still able to use
    your great maps...but hope you can fix IE11 for some of us old-timers! Thanks!
    ------------------------------------------
    Free USGS topo maps! Use CalTopo for collaborative trip planning, detailed elevation profiles and terrain analysis, printing geospatial PDFs, and exporting maps to your smartphone as KMZ or MBTiles fiels. •Print free USGS topo PDFs!
    •Export topographic maps to Google Earth and Garmin GPS as KML and KMZ files.
    •Find shared maps from other users.
    •About CalTopo

  11. Support Staff 11 Posted by matt on 19 Feb, 2019 05:03 PM

    matt's Avatar

    Sorry, this is a bug that has been fixed. Thanks for the heads-up.

  12. 12 Posted by Ginger Hite on 19 Feb, 2019 06:27 PM

    Ginger Hite's Avatar

    Thank you so much Matt...all good & running like normal now!My research is mostly related to land surveying in Colorado.So basic layers - USGS, FS Topos, Aerials & Land Management.But my very favorite is the easy access to Historic USGS maps!What a helpful tool...and sending thanks to you every time it's used!All the best...thanks again!  Ginger   -----Original Message-----
    From: matt <[email blocked]>
    To: vghite <[email blocked]>
    Sent: Tue, Feb 19, 2019 10:03 am
    Subject: Re: slow load times [Bug Reports #3738]

      #yiv3729494006 pre { width:92%;margin:10px 2%;padding:5px 2%;background:#efefef;border:1px solid #d6d6d6;} #yiv3729494006 blockquote { margin-left:0;padding-left:1em;border-left:5px solid #ccc;}

  13. matt closed this discussion on 25 Feb, 2019 04:38 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac