My map isn't working for anyone but me

Dave Benson's Avatar

Dave Benson

04 Jan, 2019 07:47 PM

I made a shared map of a hike in Orange County, CA. And it works fine for me, but if I log in "incognito", none of my features (a trail and two peaks) show up, and this seems to be everyone else's experience. Here is my map: https://caltopo.com/m/2R1C

Any ideas or suggestions?

  1. Support Staff 1 Posted by matt on 05 Jan, 2019 06:15 AM

    matt's Avatar

    I don't know what to tell you, since it loads for me in an incognito window. Can you confirm that this is still an issue? Did you make any changes?

  2. 2 Posted by David Edward Be... on 19 Jan, 2019 12:35 AM

    David Edward Benson's Avatar

    I can't reproduce except on my phone and work computer. But I'm not at work. I received another complaint here:
      https://www.meetup.com/SGV-Hikers/events/257768196/

    I'll ask the complainer if they can come here and help you debug.

    Thanks!

  3. 3 Posted by Jason on 19 Jan, 2019 03:31 AM

    Jason's Avatar

    The link doesn't work when I click on it...it goes to the full continental US. I've used Dave's links for a long time, this only stated recently.

  4. Support Staff 4 Posted by matt on 19 Jan, 2019 10:27 PM

    matt's Avatar

    Well now I can reproduce. I have a guess at what the issue is - while I'd like to change this, at the moment if you have write access to a map, all changes you make to the layer configuration automatically save for the next page load. It looks like you have the "your maps" checkbox layer turned on, which is causing issues when someone who isn't logged in to CalTopo loads the page (since the "your maps" layer only exists when you've logged in). Can you try turning that off?

  5. Support Staff 5 Posted by matt on 19 Jan, 2019 10:28 PM

    matt's Avatar

    ^ turning that off, panning the map, waiting for the page to settle, and then reloading it to make sure the new configuration saved.

  6. 6 Posted by David Edward Be... on 20 Jan, 2019 12:37 AM

    David Edward Benson's Avatar

    Aha! That does indeed seem to fix it! (And it explains why some maps are affected and not others)

  7. 7 Posted by David Edward Be... on 20 Jan, 2019 02:45 AM

    David Edward Benson's Avatar

    Thanks for your help, Matt!

  8. matt closed this discussion on 20 Jan, 2019 04:20 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac