APRS

Nate's Avatar

Nate

26 Oct, 2018 12:07 AM

I recently started having issues with locators on my maps. I have been using APRS with sartopo for about 8 months, and now locators that have been working are no longer showing up. Has there been recent changes? I've tried a few different callsigns with operators on my team with negative results.

  1. Support Staff 1 Posted by matt on 26 Oct, 2018 01:36 AM

    matt's Avatar

    How recently?

    Is this sartopo.com via APRS-IS, or SARTopo Offline via a local TNC?

  2. 2 Posted by nathan robb on 26 Oct, 2018 12:09 PM

    nathan robb's Avatar

    As far as I can tell. At least since last Friday 10/19. Using sartopo.com
    with APRS-IS and via conventional radio transmission.

  3. 3 Posted by nathan robb on 29 Oct, 2018 02:47 PM

    nathan robb's Avatar

    APRS locators are working again.

  4. Support Staff 4 Posted by matt on 29 Oct, 2018 03:00 PM

    matt's Avatar

    Yep. I don't know what happened as I don't have a lot of logging around it and the APRS-IS connection is supposed to automatically reset if something goes wrong, but things appeared hung up somehow. A server reboot last night fixed it, wanted to make sure it was still running this morning before proclaiming victory though.

  5. 5 Posted by nathan robb on 30 Nov, 2018 01:04 AM

    nathan robb's Avatar

    Matt,

    I hate to keep bugging you about this issue, but now it seems to only log
    the points for the locators, and it doesn't create a path. Is this a
    change?

    Thanks,

    Nate

  6. Support Staff 6 Posted by matt on 06 Dec, 2018 07:23 PM

    matt's Avatar

    This appears to be a bug limited to older, existing locators / groups. A new track length setting was added a while ago and older locators / groups aren't properly handled, causing them to appear to have a track length of 0. Looking at the code, I think you should have noticed this a long time ago, which makes me question whether I'm on the right track, but it's possible some more recent change brought the locator bug to the foreground.

    If edit and save an existing locator (without modifications), or edit and save a locator group (setting the track length to full) for newly-recorded locators, does the bug go away?

  7. 7 Posted by nathan robb on 07 Dec, 2018 10:24 PM

    nathan robb's Avatar

    I've been trying to understand the issue myself Nov 10th, but wasn't sure
    what it might be related to. That day we started using some beacons that
    were set up by a former member on our team that isn't around any more, they
    were just showing up as dots. Just this past week, I started using an
    AT-D878 handheld to send APRS signals and it did the same. I then tried it
    with my phone as an igate, and then with my phone through analog, these two
    methods had connected lines and were showing as a path. I'm re-creating the
    locators now, and will test tomorrow at our training and let you know.
    sartopo.com/m/n85n

  8. Support Staff 8 Posted by matt on 08 Dec, 2018 05:00 AM

    matt's Avatar

    The locators currently shown on that map have a track length properly set but only one point in their geometry, so not the issue I discovered. The track line does reset based on time/distance from the last point, so that you don't get large awkward jumps across the map. However if you're consistently never seeing a track tail, that doesn't sound like it would be the case.

  9. 9 Posted by nathan robb on 08 Dec, 2018 03:48 PM

    nathan robb's Avatar

    60s is the most frequent my radio will allow me to broadcast. Would that
    be too far apart?

  10. 10 Posted by nathan robb on 15 Dec, 2018 03:15 AM

    nathan robb's Avatar

    So I've been playing around with the settings on my radio, and it turns out
    to be something on my end. I'm happy to say things are working out now, I
    changed so many parameters I'm not sure which one's did the trick, but I
    think it had something to do with the SSID. https://sartopo.com/m/JHJA

  11. 11 Posted by jeff.sikora on 09 Mar, 2019 10:02 PM

    jeff.sikora's Avatar

    So i have read alot here but is there a way to have APRS-IS or .fi feed to a SAR topo map ? Seems like some i have read say yes others say i need the offline version.

  12. Support Staff 12 Posted by matt on 11 Mar, 2019 05:04 PM

    matt's Avatar

    Yes, the online version is linked to the APRS-IS feed. Offline reads direct from a TNC.

    For technical reasons, you have to be working off a saved map. Add Object -> Add Locator. Type APRS, callsign is the callsign without the SSID. That will create a "locator group", each individual SSID will show up as a separate locator. Doesn't necessarily make the most sense for APRS but it's a setup that works across a range of location tracking tools.

  13. 13 Posted by jeff.sikora on 12 Mar, 2019 11:56 AM

    jeff.sikora's Avatar

    Matt,

    I was on a saved map. I also put multiple call signs in and none showed up.
    All were showing on aprs.fi

    Jeff

  14. 14 Posted by nathan robb on 12 Mar, 2019 12:11 PM

    nathan robb's Avatar

    You might check your SSID, I had a similar issue that was fixed when I
    changed mine to '5'

  15. 15 Posted by jeff.sikora on 12 Mar, 2019 12:17 PM

    jeff.sikora's Avatar

    So I tried it with no SSID (kb2ztx) and also with kb2ztx-5. I also for fun
    put in some digi's the same way and nothing showed up. I'll play with it
    again this weekend. The way the program and object is laid out makes you
    think call with no "ID" on the end is a wild card but maybe i missed that.

  16. Support Staff 16 Posted by matt on 13 Mar, 2019 02:37 AM

    matt's Avatar

    That's correct, it's a wildcard and you shouldn't specify the ID. What's the map ID? Depending on when you set it up, one thing to check is the expiration time on the locator (which can be set to "never expires").

  17. 17 Posted by nathan robb on 13 Mar, 2019 02:53 AM

    nathan robb's Avatar

    I'm saying the TNC SSID needs to be set to 5 (7 has also worked for me),
    the locator beacon object on sartopo should not have a specified ssid as
    you stated.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac