Disable Apple Mouse zoom

Paul Beiser's Avatar

Paul Beiser

17 Sep, 2018 09:07 PM

howdy,

Is there a way in Caltopo to disable mouse swipes (left right, up down) so that I dont get zooms all the time? Seems like Caltopo recently has gotten extremely sensitive and it's hard for me to create a route. Google Maps behaves fine, btw.

  1. Support Staff 1 Posted by matt on 17 Sep, 2018 11:17 PM

    matt's Avatar

    Is this limited to drawing (there were some recent changes made to scrollwheel behavior while drawing), or also while using the map without drawing?

    Can you clarify what you mean by mouse swipes? I have a mac laptop but no external mouse - is this your finger causing an accidental swipe gesture on Apple's mouse?

  2. 2 Posted by Paul Beiser on 18 Sep, 2018 11:50 AM

    Paul Beiser's Avatar

    Hey Matt,
    It is not limited to drawing, but it seems a lot worse/more prevalent. When I try to Add Object (Line), all of a sudden the map zooms WAY in.

    Mouse swipe - taking a finger and either moving it left and right (or up and down) across the surface of the mouse. Google Maps has excellent behavior - up and down zooms in and out while left and right does nothing. In Caltopo, either direction now and just a slight touch causes huge zoom jumps (Google Maps is very smooth and looks like it is damped to avoid huge jumps). Hope this helps.

  3. Support Staff 3 Posted by matt on 18 Sep, 2018 06:18 PM

    matt's Avatar

    Thanks Paul. I will probably need to get my hands on an apple mouse to debug this further.

    However, changes were only made to this behavior while drawing (since I have disable Google Maps' built-in drag support, which recently had the side effect of also disabling scroll wheel zooming). Any behavior while not drawing a line should in theory be the same as on Google Maps, and I'm not sure I'll be able to fix any differences there. Sounds like fixing the behavior while drawing would get most of the way there.

  4. 4 Posted by Paul Beiser on 18 Sep, 2018 06:29 PM

    Paul Beiser's Avatar

    Thanks, Matt. I checked this out further, and yes, it seems to be isolated to drawing. Right now, drawing is unusable for me because of this behavior.

    Google Maps does NOT zoom when swiping left or right across my Apple Mouse. It zooms in when swiping up and out when swiping down and it's very smooth and has the right speed.

  5. kobe.pole closed this discussion on 26 Sep, 2018 10:48 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac