Saved Maps Not Loading

EatiusBirdius's Avatar

EatiusBirdius

02 Aug, 2018 09:05 PM

Howdy,

I've been working on a couple saved maps the past couple days to finally start using the tool. My first saved map was created just fine and had been loading all the way up until mid-day (PST). The second map, which also had been saved, was also almost done. Suddenly, when I try to load either of them now, neither loads. I simply get a blank screen in my Chrome tab. I've tried closing and reopening Chrome, clearing out Chrome's cache but all to no avail. I've also done some searching around the forums and the web to see if anyone else had similar problems but I'm not finding any solutions.

Any ideas what may be causing this issue?

Thanks!

  1. Support Staff 1 Posted by matt on 02 Aug, 2018 10:16 PM

    matt's Avatar

    Do you know what the map IDs are (the final 4 characters in the URL)?

  2. 2 Posted by EatiusBirdius on 02 Aug, 2018 10:29 PM

    EatiusBirdius's Avatar

    BHC8 and H55H

  3. Support Staff 3 Posted by matt on 03 Aug, 2018 04:32 AM

    matt's Avatar

    Both maps wound up with a pair of lines that didn't have any points attached to them, which was generating an error. I've fixed the server-side error so that you can load the page, but you should still delete those lines to make sure the map viewer works right.

    Do you have any idea how that happened? Did you import a file that might have had some odd data in it? Ideally I'd like to figure out how they got in and fix that as well.

  4. 4 Posted by EatiusBirdius on 03 Aug, 2018 04:02 PM

    EatiusBirdius's Avatar

    Howdy Matt,

    Thank you very much for all of your help and hard work. I'm very new to the tool but am amazed at it's power. I'll try my best to give you as much info as possible to help.

    Note: this is all in Version 68.0.3440.84 (Official Build) (64-bit) of Chrome and Win10 Home 10.0.17134 Build 17134.

    BHC8 came back fine and appears to have that extra line you were mentioning. It does appear though that I can't really select it via the 'Lines and Polygons' UI since it is kind of "smooshed" together (see BHC8smoosh.png). The only way I can appear to delete it is via the 'Bulk Ops" method (BHC8bulk.png). Once I deleted it via the 'Bulk Ops', everything appeared to be fine for BHC8.

    H55H however, did not come back OK after the server side fix. It only contains the last line (Day 10), which I had entered right before I ran into the problem. Lines for Day 1 thru Day 9 are missing. Don't worry about that though. I'm sure you have better things to be doing than tracking that down. I'll just recreate those lines or probably just recreate the map entirely. I did, as you mentioned, have that random extra line which appeared smooshed against the other line in the 'Lines and Polygons' interface as it did in BHC8. Going to 'Bulk Ops' was the only way to delete it.

    Let me give you some detail as to the things that led up to this issue:

    • BHC8 was generated from scratch using the tool.
    • Each day of the trip along the JMT via South Lake in Bishop was created via it's own individual Line (again, I don't know if this is the best way to go about it but it's what I tried for the first time using the tool). 10 lines in all.
    • Each Line was labeled with the Day of the trip and the associated mileage of that line in parentheses.
    • This was process was repeated until I got all the way down to Whitney Portal.
    • I then saved and exported this to a GPX file.

    • H55H was generated via the BHC8 GPX file since Day 1 through Day 3 lines would be identical and I thought I would save myself some time.

    • Day 4 through Day 10 Lines would be created at the new distances and new exit point for the trip, which I believe is called the Cottonwood Pass trail head.

    • As I got closer to finishing the map and drawing the Line for Day 10, I did notice either some client-side or server side delays in responding what I was trying to do, which was simply draw the line, label it and then see the Profile.

    • I did notice that 'last saved ##:## PM' text that appears under the Filename, was in a red color as opposed to the standard black text that is normally there.

    • Also, at one point, when trying to get the profile for that last Line (Day 10) in H55H, the profile window appeared blank and simply said 'standby...calculating'. It then never showed the profile and the page went blank with a general server error saying something to the effect that "there was a network error..." and the page went blank. I apologize but I don't recall the specifics of that error message. :-(

    • I believe that once I tried to reload the map, it came back up a couple times but the interface appeared to be moving much more slowly than previous time I was editing the maps. Almost like there were server troubles. However, without knowing the architecture of the application, I'm unsure if that was truly the case or there was some extraneous data saved from the previous session that was causing the client-side to stall. Or something else. I did try to make sure there were no connections with me locally and as far as I could tell, any other web page I could access without issue.

    • Eventually, any attempt to load the H55H returned the blank white page you saw when I initiated this post. No errors were returned via the web page nor was there any errors show in Chrome's developer console.

    • When I went back to BHC8 and tried editing the Labels for each Line in that map, I started to get similar problems as H55H above (slow response to the interface, red 'last saved...' text, I believe I even tried to look at the profile on BHC8 and it timed out with an error like H55H.

    • Eventually, BHC8 also became unresponsive and unable to load like H55H.

    Anyway, I hope that helps. Let me know if you have any questions or if I can help any further.

    Thanks!

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac