area measurement incorrect

Matt Vanderveer's Avatar

Matt Vanderveer

11 Jul, 2018 12:49 AM

Hi,

Sometime in the past few weeks, the area measurement for polygon objects started being off in SARtopo online. I drew an area that SARtopo online said was 10 acres, but when I printed it at 1:24k and measured it with my area measurement card it was closer to 40 acres (which is what I expected). I have the offline version, downloaded in March, on a laptop and the area measurement is correct in that, so this issue was introduced since then, but if IIRC, it cropped up more recently.

Thanks,

Matt

  1. Support Staff 1 Posted by kobe.pole on 11 Jul, 2018 01:18 AM

    kobe.pole's Avatar

    Hi Matt,
    We just updated our system, so this may be a bug. I'll take a look into it and see what I can do to fix it.
    -Kobe

  2. Support Staff 2 Posted by matt on 11 Jul, 2018 03:33 AM

    matt's Avatar

    Thanks for the heads up, this has been fixed.

    There were some major changes deployed Fri night that, amongst other things, swapped the lat / long coordinate ordering (to long / lat) everywhere in the codebase in order to be compatible with the GeoJSON data standard going forward.

    The coordinate ordering wasn't swapped for polygon area computations, but part of the reason it wasn't caught is that the difference depends on which part of the globe you're looking at. In my local area it was a noticeable but more subtle 30% difference, not 4x.

  3. 3 Posted by Matt on 11 Jul, 2018 05:55 PM

    Matt's Avatar

    Thanks for the quick fix. You guys rock!

    Matt

  4. kobe.pole closed this discussion on 12 Jul, 2018 04:31 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac