Area assignments: can't draw polygon

nate.berkopec's Avatar

nate.berkopec

26 Apr, 2018 12:50 AM

I can't repro this on the online version of SARTopo, but I can on the *offline* version. Windows, Chrome.

1. Add an area assignment. Draw the polygon, double click to finish.
2. Add another area assignment. You will be unable to draw the polygon, click on the map only moves it around.

  1. Support Staff 1 Posted by matt on 26 Apr, 2018 03:33 AM

    matt's Avatar

    The offline version uses OpenLayers instead of Google Maps as the map viewer, so it's not surprising there would be a bug that would only affect one version.

    Is this consistently happening every time?

  2. 2 Posted by nate.berkopec on 26 Apr, 2018 02:33 PM

    nate.berkopec's Avatar

    Yup. Seems pretty easy to reproduce.

    Nate Berkopec
    917 474 6073
    nateberkopec.com <http://www.nateberkopec.com>

  3. 3 Posted by arkelly111 on 28 Apr, 2018 01:05 AM

    arkelly111's Avatar

    I am able to reproduce this issue when using version 3927 offline. The only workaround to continue on is to hit refresh after each area assignment or to create a polygon instead and then convert. My cmd prompt window says "WARN - No mapping found for HTTP request with URI [/static/blank.html] in DispatcherServlet with name 'spring'" when the error occurs I believe?

  4. Support Staff 4 Posted by matt on 28 Apr, 2018 02:16 AM

    matt's Avatar

    That console warning is probably unrelated.

    I'm sorry, I ran into this a while ago while doing some other development work, but for whatever reason it only happened on occasion, so I didn't try accelerating a fix for it. I believe it's fixed, but that fix is rolled up with a number of undeployed changes.

    I will try to get something out early next week.

  5. Support Staff 5 Posted by matt on 12 May, 2018 04:26 AM

    matt's Avatar

    There's a new SARTopo Offline version available that fixes this.

    I'm sorry this took so long to correct. I've been making some major under-the-hood changes and kept running into issues that prevented me from deploying a new offline version. Up until now, when I was mostly adding new features rather than refactoring existing ones, I managed to get away without a separate offline build process and just deploying new versions when the site and codebase had been stable for a while.

    Clearly that needs to change going forward.

  6. 6 Posted by arkelly111 on 12 May, 2018 04:49 PM

    arkelly111's Avatar

    There are some funky things going on with the newest version that you released last night. When I copy over the .jar to my directory it has no idea what version it is (says unknown) and also told me that the newest one was available...Additionally, it is trying to show me all of the online map layers minus Google's layers. See my attached pics.

  7. Support Staff 7 Posted by matt on 12 May, 2018 05:11 PM

    matt's Avatar

    Ignore the new version warning. I don't know how I missed that but it doesn't affect anything.

    The "naip_rgb" layers at the bottom shouldn't be showing up; I'll take a look as I didn't bump into that. However, the rest of the layers are expected. I haven't had a chance to document it yet as I'm trying to roll out a fix to the previous issue before being out for most of next week, but this is the first of several steps toward improving the experience when internet is intermittently available. It shows you all layers, requests tiles via the internet if they're not available locally, and then stores them in a cache on the hard drive, so that if you accessed a layer while internet was available, those tiles will be present even when it's not.

    If you're never operating in that kind of environment and this is more of a hindrance than a help, you can add the following line to your sar.properties file:

    sarsoft.map.backgrounds=t.f,r,slope,aspect,elevation

    Where t, f and r are the layer IDs you want to include. You can derive these from the first part of the .mbtiles filename, or the URL hash on SARTopo's map viewer. If you've downloaded slope, aspect and elevation data, you should include those IDs as well even though they're not directly visible.

  8. 8 Posted by nate.berkopec on 13 May, 2018 12:21 AM

    nate.berkopec's Avatar

    > It shows you all layers, requests tiles via the internet if they're not available locally, and then stores them in a cache on the hard drive, so that if you accessed a layer while internet was available, those tiles will be present even when it's not.

    Not a huge fan of this for our use. Obviously I'll just change sar.properties, but to give you some feedback: most of the people actually operating SARTopo in the field in our unit wouldn't have the training to just "remember" which layers are offline-capable and which are not. They would probably just start selecting layers and wonder why they don't work. We work in offline-only environments ~90% of the time, so this change is more of a hassle than a benefit.

    Couple of things I can think of that would make this better:

    Don't show internet-only layers in the dropdown if you can't ping a known IP (e.g. 8.8.8.8).
    Add an icon next to internet-only layers in the dropdown

    You may already be doing or have already thought of these things. Haven't gotten to use the new version yet.

  9. 9 Posted by nate.berkopec on 16 May, 2018 11:58 PM

    nate.berkopec's Avatar

    OK - definitely a worse problem with v4035. None of my offline tiles work, at all! All 404, no error messages in the console or in the 404 responses.

    Reverting to 3927 fixes the issue.

  10. Support Staff 10 Posted by matt on 17 May, 2018 12:27 AM

    matt's Avatar

    Can you attach a recursive directory listing of your sartopo installation?

  11. 11 Posted by arkelly111 on 17 May, 2018 01:34 AM

    arkelly111's Avatar

    I'm kind of scratching my head with the latest two stable releases. To set the scene: my home internet is slow satellite internet with a very high ping. Kind of a perfect internet to test having "spotty" reception that goes in and out.

    If I have the internet turned on for my computer...the maps will eventually load via sartopo offline albeit quite slow at times even though I have all of these tiles downloaded. If I turn off my internet by turning off the wifi or by placing it in airplane mode....it pretty much will not load any tiles.

    If I immediately return to the March or February stable releases the offline tiles will become visible instantly no matter how quickly I zoom in or out on the map. Thoughts? the NAIP RGB stuff still exists with the latest build as well.

  12. Support Staff 12 Posted by matt on 17 May, 2018 05:56 AM

    matt's Avatar

    I released a new version that should fix the local file loading issues, and also temporarily scales back the non-local layers so that I can take a deep breath. Let me know of any issues; normally I wouldn't release a new offline version without some more testing, but it doesn't seem like I can make things any more broken than they currently are, and while I can roll back the latest .jar file, I can't easily roll back the "fresh install" zip file.

    I'm really sorry about this mess. The past several months have been incredibly busy personally and professionally, and I'm clearly struggling more than I expected to coordinate the development, testing and deployment of several intertwined CalTopo projects. I felt like I did a lot of testing leading up to my release on the 11th, but I guess it's surprising what you can miss when you're testing your own code on a sleep deficit.

    Things should be back to normal in another month, and until then thanks for your patience. This circus is not how I'd like to be doing things.

  13. 13 Posted by arkelly111 on 17 May, 2018 10:20 AM

    arkelly111's Avatar

    Matt,

    I feel like I can speak on behalf of a large majority of your users and let you know that you don't need to extend a big apology. Many of us are very grateful for a very streamlined, functional piece of software that comes at a very affordable price if not free for many of us.

    I myself consider myself somebody that is trying to follow your changes when they happen so that I can test them out myself to check for bugs or whatnot and post them back to you as a sort of self-made beta tester. This is to help you a lone developer with a lot of stuff in the works and to help me from being surprised when I attempt to use your software in the field on a search.

    As for the new release, it definitely has helped with the local file loading! Do you keep a running changelog anywhere that you meant consider posting somewhere for those of us that are kind of self-beta testing your software? It doesn't necessarily need to be a huge involved thing that is visible for all of your users if you are trying to avoid that.

    Thank you again for the quick fixes!

  14. 14 Posted by nate.berkopec on 17 May, 2018 03:05 PM

    nate.berkopec's Avatar

    I agree! I don't mind bugs as long as you're responsive, which you always have been! Being a software dev myself I definitely know how it goes :)

    I too would like a changelog, even if it was just some automated output from your version control.

  15. Support Staff 15 Posted by matt on 18 May, 2018 05:13 PM

    matt's Avatar

    I'll think about how to handle a changelong, but there are several reasons I don't want to just pull automatically from the version control log, at least not publicly. At some point I'd also like to launch a more formal beta testing program, as well.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac