problem with marker placement / datum conversion

Bill Atkins's Avatar

Bill Atkins

12 Feb, 2018 03:15 PM

I have had these issues recently:

1. A marker created by right-clicking on the map and entering coordinates sometimes retains the cursor position no matter what coordinates are entered.

2. A 180-foot difference in marker locations when converted between lat/lon/wgs84 and utm/nad27.

I can only reliably reproduce #2:
. set Config->datum to wgs84
. set Config->coordinate system to Degrees primary, UTM secondary
. place a marker at -37.0, -107.0
. click on the marker and select Position & Elevation
. select "Coordinates - NAD27 CONUS" from drop down menu
. observe utm for wgs, nad27 = 13S 0322038E 4096742N 13S 0322033E 4096539N
. set Config->datum to nad27
. click on marker
. observe the utm position is 13S 0322088E 4096535N (not the same as 3 steps above)
. create a marker with coordinates 13S 0322033E 4096539N
. observe that the markers are about 180 feet apart.

If I convert this way: start with a nad27 lat/lon and convert to utm wgs84, there is no error.

thanks,
Bill Atkins

  1. Support Staff 1 Posted by caver456 on 13 Feb, 2018 04:56 AM

    caver456's Avatar

    Is it possible that item 1 is due to typing coordinates into the label
    field, since the label field has focus when you open the add marker
    dialog? I've done this often.

  2. Support Staff 2 Posted by matt on 13 Feb, 2018 07:06 AM

    matt's Avatar

    Thanks. #2 is fixed; it was skipping the initial part of the conversion step, but the resulting delta in the area I tested in was far smaller, so I didn't pick it up.

    I think #1 is fixed. I could reliably reproduce it by pressing enter as I was editing the coordinate box, without tabbing or clicking out of the box first. The dialog was getting closed before the new location was read / synced.

  3. 3 Posted by bill.atkins on 13 Feb, 2018 02:15 PM

    bill.atkins's Avatar

    Thanks for the quick attention!
    Bill

  4. Support Staff 4 Posted by matt on 14 Feb, 2018 02:47 AM

    matt's Avatar

    I've released a new version of sartopo/caltopo offline with this fix as well.

  5. matt closed this discussion on 14 Feb, 2018 02:47 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac